인터페이스

이절에서는 RoboDK 소프트웨어의주요인터페이스를설명합니다.

RoboDK의메인창에는다음과같은구성요소가표시됩니다.

●메인 메뉴는상단에위치합니다. 이메뉴에서는사용가능한모든작업및옵션을사용할수있습니다.

o도구모음에는메뉴에서자주사용하는작업에빠르게액세스할수있는그래픽아이콘이포함되어있습니다. 자세한내용은도구모음섹션에서확인하십시오.

●스테이션트리는스테이션에존재하는모든구성요소(항목)를나열합니다. 이러한품목은제조또는보정목적을위한로봇, 도구, 물체, 표적또는특정설정이될수있습니다. 트리는실제환경에존재하는의존성을이해하고수정할수있게해줍니다. 예를들어, 대상을특정기준프레임에부착할수있고, 이기준프레임을로봇베이스프레임에부착할수도있으며, 로봇툴은대개로봇에부착할수있습니다.

●상태표시줄은하단에위치하며특정작업에유용한팁을보여줍니다.

●3D 보기(메인화면)는 3D 가상환경에서보기를표시하고해당계층으로스테이션트리를재현할수있습니다.  

트리또는 3D 보기에서항목을더블클릭하면항목의속성이포함된새창이표시됩니다. 예를들어로봇을두번클릭하면로봇 패널표시됩니다. 이러한창은서브창의오른쪽위에있는X 표시를선택하여닫을수있습니다.

예외적으로대상을더블클릭하면로봇이해당대상으로이동합니다. 타겟을두번클릭하는대신한번만선택하면로봇은현재위치에서해당표적에대한선형또는조인트이동을시뮬레이션합니다.

Interface - 영상 1

로봇 패널

항목트리(또는 3D 보기)에서로봇을더블클릭하여로봇패널을여십시오. 로봇축을조인트축조그섹션에서조그하고텍스트상자에특정조인트축값을입력할수있습니다. 이러한값과로봇위치는로봇컨트롤러값과일치합니다.

로봇축한계를수정하려면조인트한계를두번클릭하십시오. 기본적으로BoboDK는로봇제조업체의사양에따른하드웨어한계를사용합니다. 일부애플리케이션은더많은축한계(소프트웨어한계)를요구할수있습니다. 조인트값은해당섹션의해당버튼을사용하여값목록으로복사하거나붙여넣을수있습니다.

Interface - 영상 2

카르테시안조그섹션에는로봇운동학과관련된모든정보가표시됩니다.

●로봇플랜지(FF)에관한툴 프레임(TF)은로봇플랜지와관련하여선택된툴프레임이위치한위치를정의합니다. 로봇플랜지는항상같지만, 로봇에탑재된도구에따라툴프레임이바뀝니다. 이관계는대부분의로봇컨트롤러에서 UTOOL, ToolData 또는 Just Tool로도알려져있습니다. 로봇공구는 TCP(툴중심점)라고도합니다. 선택된툴은 "활성" 도구가됩니다. 활성도구는새대상과프로그램을생성할때사용됩니다. 선택한도구는아이콘에녹색으로표시됩니다Interface - 영상 3.

●로봇기반(BF)에관한기준 좌표계(RF)는로봇기반좌표계와관련하여기준좌표계가위치한위치를정의합니다. 로봇기반좌표계는절대움직이지않지만, 같은로봇기반좌표계에관련된어떤물체도위치시키기위해다른기준좌표계를사용할수있습니다. 이관계는대부분의로봇컨트롤러에서 UFRAME, WorkObject MFRAME 또는기준으로도알려져있습니다. 로봇패널에서선택한기준좌표계가 "활성" 기준좌표계가됩니다. 활성기준좌표계가새타겟및로봇프로그램의참조로사용됩니다. 선택한기준좌표계는아이콘에녹색으로표시됩니다Interface - 영상 4.

●기준좌표계(RF)에대한툴좌표계(TF)는로봇의현재위치에대한활성기준좌표계에대한활성 TCP의위치를보여줍니다. 로봇을이동하려면이값을수정하십시오. 조인트축은자동으로재계산됩니다. 이러한카르테시안좌표는새타겟이생성될때로봇축과함께기록됩니다(프로그램➔타겟추가). 타겟또한활성기준좌표계에연결됩니다.

가능한구성목록은기타구성섹션에서확인할수있습니다. 로봇구성은특이점을교차하지않고로봇의특정상태를정의합니다. 구성을변경하려면특이점을넘어야합니다. 자세한내용은로봇 구성섹션을참조하십시오.

마지막으로, 오른쪽위의매개변수버튼을사용하면로봇보정프로젝트후에선호하는포스트프로세서를선택하거나정확한파라미터를추출하여약간의운동학적조정을할수있습니다. 이러한값은특정상황에서만수정해야합니다.

영상: 다음영상은RoboDK의로봇과로봇패널에대한일반적인개요를제공합니다.

https://www.youtube.com/watch?v=z357z1NlkZM&list=PLjiA6TvRACQd8pL0EnE9Djc_SCH7wxxXl&index=8

로봇 툴 (TCP)

로봇툴Interface - 영상 5을더블클릭하여해당도구에대한자세한내용을확인하고로봇플랜지에대한툴좌표계(눌중심점또는 TCP라고도함)의위치를수정하십시오.

추가 옵션...을선택하면툴형상에축척인자를적용하거나로봇플랜지를기준으로형상을이동할수있습니다. 이러한값을변경해도로봇프로그램에는아무런영향을미치지않습니다. 형상은표시목적과충돌검사에사용됩니다 (TCP를그대로유지).

Interface - 영상 6

영상: 다음영상은로봇툴(TCP)에대한일반적인개요를제공합니다.

https://www.youtube.com/watch?v=FltOFBCzx-w&list=PLjiA6TvRACQd8pL0EnE9Djc_SCH7wxxXl&index=11

기준 좌표계

기준좌표계에대한자세한내용을보려면기준좌표계Interface - 영상 7를더블클릭하고로봇기반좌표계또는스테이션에서사용할수있는다른기준좌표계에대한위치를수정하십시오. 기본적으로표시되는좌표(포즈)는기준좌표계의상위(이예에서는로봇기반좌표계)에상대적입니다.

Interface - 영상 8

실제애플리케이션에존재하는종속성을구축하기위해여러개의기준좌표계가서로연관될수있습니다. 예를들어, 테이블은로봇과관련하여특정위치에있을수있습니다. 그런다음, 표에있는두개이상의객체가테이블참조와관련하여특정위치에있을수있습니다. 테이블참조를이동하면객체와테이블사이의관계가변경되지않고로봇과관련된모든객체의관계가변경됩니다. 다음의그림은이러한예를보여줍니다.

Interface - 영상 9

로봇 타겟

로봇타겟을사용하면특정로봇위치를기록하여해당위치로로봇을이동할수있습니다.

다음단계에따라새대상을추가하고여기에첨부된정보를확인하십시오.

●새로운타겟생성을위해프로그램 ➔ Interface - 영상 10 타겟 추가(Ctrl+T)를선택하십시오.           
그러면활성기준좌표계와활성툴좌표계를사용하여로봇의현재위치가기록됩니다. 타겟이활성기준좌표계에추가될것입니다.

●타겟을마우스우측버튼으로누른후옵션...(F3)를선택하여기록된포즈및조인트값을확인하십시오.

Interface - 영상 11

새로운타겟을생성하면현재로봇축뿐만아니라카르테시안공간의기준좌표계에관한 TCP를기록합니다. 기본적으로 RoboDK는대상을카르테시안타겟으로생성합니다(카르테시안 위치 유지 Interface - 영상 12). 이경우기준좌표계가이동되면로봇은해당기준좌표계에대해타겟위치에도달하려고시도합니다.

한편, 조인트공간에서타겟을지정할수있습니다(조인트값 유지Interface - 영상 13). 이경우타겟은절대로봇위치이며기준좌표계가이동해도변경되지않습니다.

조인트타겟을사용해작업구역에가까운첫번째접근위치에도달한다음, 기준좌표계나툴좌표계를수정했을때툴경로가변경되지않도록하는것이일반적인관행입니다.

로봇과같은자세를취하기위해다른구성을볼수있습니다. 섹션에서좀더자세한정보를확인할수있습니다.

로봇 구성

하나의로봇구성은로봇의특정상태를정의합니다. 구성을변경하려면특이점을넘어야합니다. 로봇컨트롤러는선형이동이이루어질때특이점을넘을수없습니다(이를위해서는조인트이동이필요합니다).

즉, 두타겟사이에서선형이동을수행하려면첫번째지점과마지막지점을포함하여완전한이동에대해로봇구성이같아야합니다.

로봇을마우스우측버튼으로클릭하고구성 변경을선택하여로봇구성창을여십시오. 로봇패널에서추가 옵션을선택하여이창을열수도있습니다.

Interface - 영상 14

표준 6축로봇의경우각로봇축이한바퀴완전히움직일수있다고가정할경우로봇의어떤위치에도일반적으로 8개의다른구성이있습니다. 실제로관절한계는로봇에따라다소구속될수있습니다. 따라서, 로봇에따라특정위치에대해 1개에서 100개이상의로봇구성을가질수있습니다.

Interface - 영상 15Interface - 영상 16Interface - 영상 17Interface - 영상 18Interface - 영상 19Interface - 영상 20Interface - 영상 21Interface - 영상 22

하나의로봇구성은로봇과의위치에도달하는특정한방법(조립모드)을정의합니다. 예를들어, 로봇은팔꿈치를위로올리거나팔꿈치를아래로향하게하거나 (상단대하단또는 U / D) 동시에타겟을향하거나베이스가 180도회전하여타겟을뒤로도달할수있습니다 (앞면대후면또는 F / R). 마지막으로조인트 5는축 4와축 6을동시에전환하여부호를전환하여뒤집을수있습니다(플립대논플립또는 F / N). 전체적으로 2 * 2 * 2 = 8 구성을제공합니다.

객체 설정

객체는 STL, STEP 또는 IGES 형식과같은일반파일형식에서가져올수있습니다. 트리또는 3D 보기에서개체를두번클릭하여설정창을여십시오.

Interface - 영상 23

기준좌표계와관련하여위치를설정하거나볼수있습니다. 그러나개체는일반적으로기준좌표계에설정되며개체를이동해야하는경우기준좌표계를이동하는것이좋습니다. 특정시뮬레이션이벤트가발생한후로봇툴로객체를잡을수도있습니다.

추가 옵션... 메뉴를통해객체색상을변경하거나, 축척비율을적용하거나, 자신의기준좌표계에대해형상을이동할수있습니다.

메인 메뉴

메인메뉴에는사용가능한모든옵션이포함되어있습니다. 메인메뉴는다음섹션으로나뉩니다.

1.파일 메뉴:새파일가져오기(3D 기하학, 로봇, 툴, 툴경로등) 및RoboDK 프로젝트열기또는저장(RDK 파일확장자) 등을제공합니다.

2.수정 메뉴:항목또는항목그룹을잘라내거나복사/ 붙여넣기, 실행/취소/재실행작업을할수있습니다.

3.프로그램 메뉴:OLP(오프라인프로그래밍)를위한로봇프로그램및기타관련옵션을만들거나수정할수있습니다.

4.보기 메뉴:3D로탐색하고특정보기를설정하는유용한동작을제공합니다.

5.도구 메뉴:충돌확인, 측정지점또는주요옵션열기등의일반도구를제공합니다.

6.유틸리티 메뉴:제조작업에로봇사용, TCP 또는기준좌표계보정, 로봇을 3D 프린터로사용하거나 5축 CNC로사용하여로봇보정등특정작업을수행할수있습니다. 이러한작업에는특정라이선스옵션이필요할수있습니다.

7.연결 메뉴:로봇, 측정시스템또는시뮬레이션카메라에연결할수있습니다.

8.도움말 메뉴:온라인설명서(F1)를열수있도록허용하고업데이트를확인하거나라이선스를설정할수있습니다.


 

파일 메뉴

파일메뉴에서는문서를열거나저장하거나내보낼수있습니다.

Interface - 영상 24새 스테이션은트리에새스테이션을추가합니다. 하나의스테이션을하나의 RDK 파일로불러오거나저장할수있습니다. RDK 파일 (RDK 확장명)에는로봇및객체에대한모든정보가포함되므로가져온항목의사본을별도로보관할필요가없습니다.

Interface - 영상 25열기는새로운 RoboDK 파일 (RDK Station)을로드하거나로봇파일용 .robot, 객체용 STEP / IGES / STL, 공구파일용 .tool 등인식가능한다른파일형식을가져옵니다.

Interface - 영상 26온라인 라이브러리 열기는온라인으로사용할수있는라이브러리가있는새창이표시됩니다.

Interface - 영상 27스테이션 저장은RDK 파일을저장합니다. 저장하는파일의위치를제공하려면Interface - 영상 28스테이션 다른 이름으로 저장을선택하십시오.

Interface - 영상 29데모 스테이션 생성은스테이션을RoboDK의간소화된버전과함께 EXE 파일로내보내줍니다.  

 Interface - 영상 30시뮬레이션 내보내기는특정프로그램이나시뮬레이션을 3D PDF 또는 3D HTML 파일로내보냅니다. 예제

Interface - 영상 31

수정 메뉴

실행취소(Ctrl+Z) 및다시실행(Ctrl+Y) 작업은편집메뉴에서액세스할수있습니다. 실행취소동작의기록도사용할수있으며, 동작을선택하여변경사항을뒤로또는앞으로되돌릴수있습니다.

스테이션트리에서한항목또는항목그룹을잘라내기Interface - 영상 32(Ctrl+X), 복사Interface - 영상 33(Ctrl+C) 또는붙여넣기Interface - 영상 34(Ctrl+V)도가능합니다. 어떤항목을복사하면그것에부착된모든항목이복사됩니다.

Interface - 영상 35

Interface - 영상 36

프로그램 메뉴

프로그램메뉴에는오프라인프로그래밍및프로그램생성과관련된모든구성요소가포함되어있습니다. 로봇에새로운프로그램, 기준좌표계, 타겟또는툴을추가하는것이가능합니다. 이러한오프라인프로그래밍구성요소(기준좌표계, 툴, 타겟등)는오프라인에서생성된모든프로그램에나타납니다.

Interface - 영상 37기준 좌표계 추가를선택하면스테이션루트에부착되거나다른기준좌표계에부착된새기준좌표계가추가됩니다.

 Interface - 영상 38툴 (TCP) 추가는로봇에새로운 TCP를추가합니다. 새공구를추가하기위해형상이필요하지않습니다. 여러도구를사용하면하나의도구에연결된같은형상의다른부분을참조할수있습니다.

Interface - 영상 39타겟 추가 (Ctrl+T)는활성로봇툴의활성기준좌표계에새타겟을추가합니다. 로봇 패널에서활성기준좌표계와활성툴을선택할수있습니다. 기준좌표계나툴을마우스우측버튼으로클릭하여활성화할수도있습니다.

Interface - 영상 40표면에 타겟 추가 (Ctrl+Shift+T)를사용하면타겟을쉽게선택할수있도록객체의점을선택할수있습니다. 이 섹션에서예제를볼수있습니다.

Interface - 영상 41 프로그램 추가는 RoboDK GUI (그래픽사용자인터페이스)를사용하여만들수있는새프로그램을추가합니다. 이유형의로봇프로그램을작성하거나수정하는데프로그래밍경험이필요하지않습니다. 로봇프로그램을특정로봇에대해자동으로쉽게시뮬레이션하고생성할수있습니다.

오프라인프로그래밍문서의프로그램 명령섹션은 GUI를통해사용가능한프로그램명령에대한자세한정보를제공합니다.

Interface - 영상 42파이썬 프로그램 추가옵션은스테이션에 RoboDK API에연결되는샘플파이썬프로그램 / 매크로 / 스크립트 / 모듈을포함합니다. RoboDK API를사용하는파이썬프로그램을사용하면일반파이썬프로그래밍코드에서로봇프로그램을작성할수있습니다. 특정로봇컨트롤러에이러한프로그램을배포할수있습니다. GUI 프로그램을확장하기위해특정작업을시뮬레이션할수도있습니다. 이러한작업은오프라인프로그래밍, 온라인프로그래밍을위한로봇서브프로그램일수있으며, 픽앤플레이스시뮬레이션을위해임의의지점에자동으로객체를표시하는것과같은특정이벤트를시뮬레이션할수있습니다. 파이썬프로그램은스테이션에내장된텍스트파일과같으며 RoboDK의특정작업을자동화하는파이썬코드를포함합니다. RoboDK API는기본적으로파이썬을사용하여배포되지만, RoboDK와인터페이스하는데다른프로그래밍언어를사용할수있습니다.

Interface - 영상 43포스트 프로세서 추가 또는 편집메뉴입니다. 포스트프로세서는특정로봇컨트롤러에대해프로그램이생성되는방식을정의하여공급업체별구문을수용할수있습니다. 포스트프로세서는오프라인프로그래밍프로세스의최종구성요소입니다.

Interface - 영상 44

뷰 메뉴

3D로탐색하는데필요한대부분옵션은보기메뉴에서사용할수있습니다. 이메뉴에서회전, 상하좌우이동및확대/축소가가능합니다(3D 보기우측클릭). 이는마우스대신노트북터치패드를사용하여 3D로탐색할때유용합니다.

임의의방향으로자유회전을허용하려면다음옵션을선택해제하십시오 (보기➔회전정렬). 그렇지않으면 RoboDK는기본적으로 XY 평면을수평으로유지하기위해스테이션참조를잠급니다.

별표키(*)를선택하여로봇작업공간을표시하거나숨길수있습니다. F7 키를선택하여표시항목과보이지않는항목을전환할수도있습니다.

Interface - 영상 45

도구 메뉴

3D 보기의스냅샷생성, 로봇추적활성화, 충돌점검또는측정지점좌표활성화와같은일반도구를도구메뉴에서사용할수있습니다.

Interface - 영상 46궤적을활성화하면모든로봇의이동경로를볼수있습니다.

Interface - 영상 47 충돌 검사는충돌검사를활성화또는비활성화합니다. 충돌검사가활성화되면충돌상태에있는개체가빨간색으로표시됩니다.Interface - 영상 48  충돌 맵은어떤객체상호작용을점검할것인지지정합니다.

Interface - 영상 49 색상 변경 도구는로봇및객체의색상을변경할수있는작은창을표시합니다. 표면의법선벡터를뒤집을수도있습니다.

Interface - 영상 50측정은로컬기준좌표계또는스테이션기준좌표계(절대측정)와관련하여 3D 측정포인트를허용하는창을표시합니다.

도구 ➔ 언어를선택하여 RoboDK 응용프로그램의언어를지정하고원하는언어를선택할수있습니다. 선택한언어로 RoboDK가즉시표시됩니다.

도구 모음 레이아웃을사용하면기본툴바를설정할수있습니다. 또는사용법을위한최소표시및모두표시로도구모음을지정할수있습니다.

기본옵션메뉴를열려면Interface - 영상 51옵션을선택하십시오. 자세한내용은옵션 메뉴섹션에서확인하십시오.

Interface - 영상 52

유틸리티 메뉴

유틸리티메뉴를통해특정작업을수행할수있습니다.

Interface - 영상 53 툴 좌표계 정의 (TCP)를사용하면조인트구성과같은실제설정에서데이터를제공하여로봇오리엔테이션을보정하여다른방향을사용하는지점에도달할수있습니다. 이절차는일반적으로대부분로봇티치펜던트에서사용할수있습니다. RoboDK를사용하면원하는만큼많은구성으로 TCP를교정할수있습니다. 더많은구성을사용하면보다정확한 TCP 값을얻을수있습니다. TCP 교정에 대하여 보다 자세히 확인하십시오.

Interface - 영상 54 기준 좌표계 설정(사용자 좌표계)을통해로봇기본좌표계에대한기준좌표계를식별할수있습니다. 이를통해실제설정에서가상환경으로부품을정확하게일치시킬수있습니다. 기준프레임교정에대해자세히알아보십시오. 기준 좌표계 교정에 대해 자세히 알아보십시오.

Interface - 영상 55 외부 축 동기화를통해하나이상의외부축과로봇을하나의로봇메커니즘으로설정할수있습니다. 자세한정보는외부축섹션에서확인할수있습니다.

Interface - 영상 56 로봇 가공 프로젝트는공작기계경로를로봇프로그램으로쉽게변환할수있습니다. RoboDK는일반 G 코드또는 APT 파일과같은 CAM 소프트웨어를사용하여5축 CNC 용으로만든프로그램을가져올수있습니다. 이러한프로그램 / 툴경로는 RoboDK를사용하여쉽게시뮬레이션하고로봇프로그램으로변환할수있습니다. 이 섹션에서더많은정보를얻을수있습니다.

Interface - 영상 57 커브 추종 프로젝트는로봇가공프로젝트와비슷하지만 3D 형상에서추출한커브를공구경로로선택할수있습니다. 곡선가져오기를선택하여 CSV 또는 TXT 파일에서 3D 곡선을가져올수도있습니다. 이곡선은 XYZ 점및선택적으로 IJK 벡터의목록으로제공되어야합니다. 곡선에서사용가능한추가정보는커브 추종 프로젝트섹션을따릅니다.

Interface - 영상 58 포인트 추종 프로젝트는로봇가공프로젝트와유사하지만 3D 형상에서추출한포인트를선택하고로봇공구경로를쉽게만들수있습니다. CSV 또는 TXT 파일에서 3D 포인트를가져오기위해포인트가져오기를선택할수도있습니다. 이러한포인트는 XYZ 점및선택적으로 IJK 벡터의목록으로제공되어야합니다. 보다자세한정보는포인트 추적 프로젝트섹션을따릅니다.

3D 인쇄프로젝트를선택하여특정개체에대한로봇 3D 인쇄프로그램을생성하십시오. 객체는 RoboDK 스테이션에서사용가능해야합니다. 3D 인쇄공구경로는슬라이서(slicer)를사용하여장면뒤에서 G 코드로변환된다음3축가공공구경로처럼처리됩니다. 로봇 3D 프린팅섹션에서자세한정보를얻을수있습니다.

볼바정확도시험은Telescoping Double Ballbar 장치를사용하여로봇성능을점검할수있습니다. 로봇볼바테스트에대한자세한내용은https://robodk.com/ballbar-test. 을참조하십시오.

Interface - 영상 59 로봇 보정로봇교정을통해로봇보정프로젝트를설정하여로봇정확도를개선하고로봇오류매개변수를찾을수있습니다. 보정된로봇은모든 RoboDK 오프라인프로그래밍프로젝트에서사용될수있습니다. 로봇보정은일반적으로로봇모델에따라로봇정확도를5배이상향상시킵니다. 로봇보정은로봇측정을위해측정시스템을사용해야합니다. 로봇정확도및반복성은교정전및 / 또는후에 ISO-9283으로테스트할수있습니다. 로봇보정및성능테스트에대한자세한내용은https://robodk.com/robot-calibration을참조하십시오.

Interface - 영상 60

연결 메뉴

로봇에연결하고로봇 IP, FTP 사용자이름및 FTP 암호와같은연결매개변수를입력할수있습니다. 로봇연결을설정하면 FTP를통해프로그램을전송하거나 PC에서직접실행중인프로그램을전송할수있습니다.

새로운로봇드라이버는최종사용자가개발할수있으며, 로봇 드라이버 섹션에서더많은정보를얻을수있습니다.

레이저측정기또는 Creaform Optical CMM과같은측정시스템에연결할수도있습니다. 이를통해로봇교정및성능테스트를완전히자동화할수있습니다.

Interface - 영상 61

도움말 메뉴

Interface - 영상 62 도움말 (F1)은이설명서를온라인으로엽니다. 각섹션상단에서 PDF 버전의설명서를내려받을수있습니다. F1을누르면 RoboDK는현재선택된항목과관련된도움말항목을표시합니다.

업데이트 확인...을선택하여업데이트를사용할수있는지확인하십시오. 권장업데이트와함께메시지가나타나거나현재버전이이미최신버전임을알려줍니다. 메시지가뜨지않으면방화벽이 RoboDK와인터넷사이의통신을차단하고있다는것을의미합니다.

Interface - 영상 63

모던 아이콘

RoboDK 5.7 이상버전에서는재설계된아이콘을사용할수있으며, 도구➔옵션➔일반➔모던 아이콘 사용에서활성화할수있습니다. 아래표는주요아이콘과새로운디자인에대한개요를보여줍니다.

레거시

모던

 

Interface - 영상 64

Interface - 영상 65

열기
새파일(RoboDK RDK 스테이션) 또는지원되는파일형식(로봇, 공구, STEP, IGES, STL 등)을불러옵니다.

Interface - 영상 66

Interface - 영상 67

온라인 라이브러리 열기
온라인라이브러리(로봇, 공구및샘플객체)를표시합니다.

Interface - 영상 68

Interface - 영상 69

스테이션 저장
RoboDK 스테이션(RDK 파일)을저장합니다.

Interface - 영상 70

Interface - 영상 71

실행 취소
마지막명령을실행취소합니다(Ctrl+Z).

Interface - 영상 72

Interface - 영상 73

다시 실행
마지막명령을다시실행합니다(Ctrl+Y).

Interface - 영상 74

Interface - 영상 75

기준 좌표계 추가
기준좌표계를사용하면객체를서로에대해배치할수있습니다.

Interface - 영상 76

Interface - 영상 77

새 타겟 추가
로봇타겟은기준좌표계를기준으로하거나관절좌표로로봇위치를기록합니다.

Interface - 영상 78

Interface - 영상 79

전체 맞춤
모든항목이표시되도록 3D 뷰를업데이트합니다.

Interface - 영상 80

Interface - 영상 81

등각 투상 뷰

기본 3D 등각투상뷰를표시합니다.

Interface - 영상 82

Interface - 영상 83

기준 좌표계 이동
화면에서드래그하여기준좌표계를이동합니다(Alt 키를누른상태).

Interface - 영상 84

Interface - 영상 85

TCP(로봇 공구) 이동
화면에서드래그하여로봇 TCP를이동합니다(Alt+Shift 키를누른상태).

Interface - 영상 86

Interface - 영상 87

충돌 확인
충돌검사를활성화또는비활성화합니다. 자세한내용은충돌섹션에서확인할수있습니다.

Interface - 영상 88

Interface - 영상 89

빠른 시뮬레이션
시뮬레이션 속도를가속화합니다(스페이스바를누른상태).

Interface - 영상 90

Interface - 영상 91

시뮬레이션 일시정지
스페이스바를눌러시뮬레이션을다시시작할수있습니다.

Interface - 영상 92

Interface - 영상 93

프로그램 추가
시뮬레이션및프로그램생성을위한새로봇프로그램을추가합니다.

Interface - 영상 94

Interface - 영상 95

Python 프로그램 추가
새 Python 매크로를추가합니다.

Interface - 영상 96

Interface - 영상 97

관절 이동 명령
새관절이동명령을추가합니다.

Interface - 영상 98

Interface - 영상 99

직선 이동 명령
새직선이동명령을추가합니다.

Interface - 영상 100

Interface - 영상 101

시뮬레이션 내보내기
프로그램또는시뮬레이션을 3D PDF 또는 3D HTML 파일로내보냅니다. 예제.