Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect to UR5
#51
I am experiencing some issues trying to connect to a UR3e 

The log as shown:

Process stopped
Sending command...
Driver apiur not running
Disconnected
Stopped
Starting robot driver: C:/RoboDK/api/robot/apiur.exe
Starting...
RoboDK driver for UR v3.9.0
Loading settings: C:/Users/kyle.watson/AppData/Roaming/RoboDK-Drivers/apiur.exe.ini
MoveJ with Joints: Yes
MoveL with Joints: Yes
MoveL as: movel(...)
Controller Version: 3
Communication Timeout (ms): 1000
Disconnected
Sending command...
Driver apiur not running
Disconnected
Error: Process crashed (id 1)
Stopped


The ping is successful and remote control is enabled as well as active when I try to establish connection. After hitting connect the bar flashes red and says stopped. I have double clicked disconnect and tried many times.
#52
(09-02-2019, 10:06 PM)Albert Wrote: Let's try to set up the UR driver manually:
  1. Take the file attached and update the IP and port in the first 2 lines (IP of the robot and the communication port you specify in RoboDK).
  2. You can load the attached file on the robot and run it (you'll need to setup a new program to run a script file as shown here).
  3. You may see errors in the log (let me know if this is the case).
If you don't see any errors it means something is blocking the connection (firewall, antivirus or Windows user account control doesn't let you setup a server connection).

I tried to run this program but this error popped up.

   

Albert, maybe you have any other ideas?
  




Users browsing this thread:
1 Guest(s)