Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Epson-LS3-401S + assembly import bug
#1
Dear Robodk Team and community,

I have found a little bug connecting to Epson-LS3-401S. The end positions are set wrong by default. The home position is at 90 0 0 0, but the limit degrees are set to -132 to +132, so the rotation is allowed to one site for 42degree and the other 222. I made it to work with repaired -132+90 and +132+90 degrees, but it is weird.


I have an assembly file that I have to import with a lot of cylindrical parts (to do pick and place action with them). I am using Solid edge for modeling. After several tries of import (iges, STP 242 and 214 and 203) every time I got the "Loading finished" message, but models haven't appeared. (I turned on the "ask for assembly vs part" option and tried fast and default too). I am not sure about a pattern option in it, but another option is to write a script to place them in the right place.
I am linking some pictures about the problems, and the assembly step file.

Thank you in advance


Attached Files Thumbnail(s)
   
Image(s)
   

.stp   Base_with_boxes_for export robodk.stp (Size: 930.64 KB / Downloads: 48)
#2
Are you using the SolidEgde plugin to import the piece in RoboDK?

I joined a station with the loaded object and the fixed robot joint.
If you want to have the tubes as separate object, hide the tubes in Solidedge before importing the assembly to RoboDK or split the object in RoboDK.


Attached Files
.rdk   StationWithLoadedObject.rdk (Size: 1.33 MB / Downloads: 48)
#3
(03-02-2022, 12:59 PM)Olivier Wrote: Are you using the SolidEgde plugin to import the piece in RoboDK?

I joined a station with the loaded object and the fixed robot joint.
If you want to have the tubes as separate object, hide the tubes in Solidedge before importing the assembly to RoboDK or split the object in RoboDK.

I tried SE plugin, but I thought it imported the assembly as one part, but after splitting, it gave me every part separately. I got them outside of the "one big part" and I made them objects then renamed them with "Rename Group". Now I see how it works.

Thank you for fixing the robot's coordinate system. Could you tell me how you managed to fix the 0 coordinate of the robot, please?

Thank you for everything, you saved my day.
#4
To modify the robot, go into the robot parameters and unlock the advanced options. You can modify the DH parameters there.

   
  




Users browsing this thread:
1 Guest(s)