Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error Connecting To Robotiq 2f-85
#1
Question 
I have been attempting to use a URscript from RoboDk to control my physical gripper (not just in simulation) for an application at uni and I working on and I am running into an error that I am not sure how to solve at this point. 

The error I got was "MODBUS Signal Gripper_Status1 has been deleted"

I am wondering if anyone has ever had this error and could please offer any advice on how to solve this? I had attached my current code.

Any help would be much appreciated, as I have read similar forum posts but can't see get a straight answer in how these issues are resolved.

Thanks in advance
#2
You did not attach any code.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Hey Sorry! I thought I had attached it - It should now be attached here. 

Thanks.


Attached Files
.txt   URprogramGripper.txt (Size: 4.32 KB / Downloads: 26)
#4
Are you trying to use "Run on robot" or "generate robot program"?

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#5
I am currently trying to just generate a robot program - I have editeded this code a little after exporting it though. The gripper movements came out as "MoveL" and I changed to "RQ_2FG_Open()"
#6
You should make sure you are using the Universal Robot RobotiQ post-processor.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)