Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Programs produced by RoboDK for 3D print on KUKA KR6 (KRC4) cannot be selected
Hi Jeremy,

Hope all is good with you. As requested please find the zipped RDK file and the HMI screen images attached.

Looking forward to a solution to this problem so I can move things forward. The KRL .src file produced from this simple example (as with others I have tried) cannot be selected on the HMI. I have used the Default KRC4 AND KRC2 post processors but the result is the same. 

Looking forward to a resolution.

Best Wishes


Attached Files
.zip   Albert (Size: 895.64 KB / Downloads: 356)
.zip (Size: 25.24 MB / Downloads: 369)
Hi Andy, 

At first I don't see anything obviously wrong in your project. 

Therefore you will need to do some debugging process. 

1 - Have you tried creating a simple program and send it to the controller? I don't mean a simple 3D printing program, just a simple program, let's say three points forming a triangle with MoveJ in between. 
You need to know if you are able to simple move the robot. 

Cause right now, you are debugging a program that is 2500 x 58 lines long... It's not an easy task. In fact, I don't ever recommend you to do testing with program that long, you are shooting yourself in the foot, because so many things can go wrong that it becomes hard to point out what is actually going wrong in this specific situation.

2 - Have you tried the KRC 4 DAT post processor? KRC 6 controllers are maybe a bit more rigid and absolutely need their .dat file. 

Have a great day.
Hi Jeremy,

Hope all is good with you and Albert.

I am working with Dr. Tao Yhang and we are in the final stages of integrating our extruder equipment to the KUKA Robot test cell for 3D printing. The extruder is controlled by an Arduino Mega 2560 and in order to Calibrate the Extruder with the Robot feed speed and the Stepper motor for controlling the Extrusion Rate he has written a Python program which reads the robot KRL code and calculates the Rotation of the stepper motor for each movement.

He has modified the post processor to achieve this and it works successfully. The only problem is that it is extremely slow to read the code. Do you have any clever suggestions for overcoming this, and speed up the process ??

Looking forward to your reply at your earliest convenience.

Best Wishes

Hi Andrew,
I am curious, how is your Arduino connected to the robot controller or in other words, how do you transfer the necessary data to the board? From your post alone I can not see what your setup is and what might be slowing down the process.
My clone arduino uno not able to connect a port to my windows 10 i also installed proper driver please what is the exact problem.

Users browsing this thread:
1 Guest(s)