Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TCP needs to be set in the driver?
#1
Hello Community,

Maybe someone can help answer the question below.

"TCP needs to be set in the driver in order to perform linear move"

I get this error from the Staubli Machining post processor whenI give it a MoveL command. The simulation changes to "Unknown status" and the robot stops. What could be the cause and what does this error mean what the log prints out? TCP is calibrated, the tool is active.
#2
Do you have a "settool" instruction in your program?
I think the Staubli Post and Driver needs it.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Thank you Jeremy for your answer.

If I define the tool in the beginning of the program with settool the MoveL command still not working (the MoveJ does) and the simulation changes to "Unknown status" and the gives me a soft limit reached error.

If I do not define the tool at the beginning of the program, the previously posted error will be written to the RoboDk log.

I don't really understand how these are related. Did I overlook something?
There are two targets in the program, a few inches apart, and nothing else. that's why I didn't share it either. I'm sharing now.

I want to be able to run the robot with the RunOnRobot command and run all the code. I'm stuck at MoveL at the moment.


Attached Files
.rdk   Testing.rdk (Size: 295.38 KB / Downloads: 74)
  




Users browsing this thread:
1 Guest(s)