Search Results
Thread: Function for automatic "Get Position" when running a program on robot
Post: RE: Function for automatic "Get Position" when run...
This is what my "Get_Position" macro in my RDK station looks like: [attachment=2900] The only thing I did was to copy the script from the post by Albert and paste it into the Macro.  Code:# Type help...
11 Replies 4,009 Views
Thread: Circular Blade rotates on last move before lifting up to safe height
Post: RE: Circular Blade rotates on last move before lif...
Thanks Jeremy, I took your advice to find a way in DXF2Gcode settings and made a simple fix. In DXF2Gcode I have deleted the default input under Options>Postprocessor Configuration>Counter Clo...
3 Replies 831 Views
Thread: Tool Orientation is not following path
Post: Tool Orientation is not following path
Hi Guys, I have set up a station Kuka Robot as per attached. There are 3 shapes to be cut with a circular saw tool, which means that we have selected "Tool Orientation follows path" as the default ...
2 Replies 961 Views
Thread: IO Outputs not activated when running robot with RoboDK
Post: RE: IO Outputs not activated when running robot wi...
Thanks Albert, I will try your advice and let you know the outcome. Some questions though, 1. On our Kuka Robot the Output number 1 is named Waterjet and Output number 2 is named Blade. You mentio...
3 Replies 1,817 Views
Thread: Circular Blade rotates on last move before lifting up to safe height
Post: Circular Blade rotates on last move before lifting...
Hi Guys, I am running a Kuka KR210 to cut stone countertops with a circular blade tool.  Currently, we import all countertops sizes into a DXF file from a laser measurement system and nest it in the...
3 Replies 831 Views
Thread: Function for automatic "Get Position" when running a program on robot
Post: RE: Function for automatic "Get Position" when run...
[attachment=2879]Hi Guys, It has been a while since the last post! To date, we have been selecting Get Position manually to run the Kuka Robot directly from RoboDk. However, I have tried to apply t...
11 Replies 4,009 Views
Thread: Setting defaults in PROGRAM EVENTS
Post: RE: Setting defaults in PROGRAM EVENTS
(12-21-2021, 02:39 PM)Jeremy Wrote: Go to "Tools"->"Options"->"CAM"->"Program Events". You can set default values for the Robot Machining Projects there, including Program Events, Orienta...
2 Replies 704 Views
Thread: Setting defaults in PROGRAM EVENTS
Post: Setting defaults in PROGRAM EVENTS
Hi guys We have a Kuka KR210 KRC-2 robot which we control with RoboDK to saw Quartz and Granite kitchen countertops. We import dxf drawing files of the pieces which we cut from big slabs. When we im...
2 Replies 704 Views
Thread: Function for automatic "Get Position" when running a program on robot
Post: RE: Function for automatic "Get Position" when run...
Hi Jeremy In the meantime, I have created a "Get_Position" macro which I opened in RoboDK for offline programming. My intention was to create a main program which would call the "Get_Position" macro...
11 Replies 4,009 Views
Thread: Function for automatic "Get Position" when running a program on robot
Post: RE: Function for automatic "Get Position" when run...
Thanks Jeremy Just a quick question before I start studying Python macros and API on the link you have sent me: I need the "Get position" macro to affect every program that I run automatically witho...
11 Replies 4,009 Views
Thread: Default PTP speed too fast
Post: RE: Default PTP speed too fast
(12-23-2020, 05:24 AM)Jeremy Wrote: Hi Curt, Sorry for the delay, I forgot to answer this one. Looking at the second print screen of your Dec 11th post, lines 20 and 21, we see that the PTP speed...
17 Replies 6,929 Views
Thread: Default PTP speed too fast
Post: RE: Default PTP speed too fast
[attachment=1717]Hi Jeremy Thank you for your patience! I have copied your KUKA_KRC4_Slow post as per insert below. [attachment=1714] I then changed the script to activate KRC2 as script insert bel...
17 Replies 6,929 Views
Thread: Function for automatic "Get Position" when running a program on robot
Post: RE: Function for automatic "Get Position" when run...
(12-14-2020, 04:45 PM)Albert Wrote: Hi Curt, You could have a simple script like the following example to retrieve the robot position from the real robot and update it in the simulation. Example:...
11 Replies 4,009 Views
Thread: Default PTP speed too fast
Post: RE: Default PTP speed too fast
(12-08-2020, 03:20 PM)Jeremy Wrote: Hi Curt,  You should be able to "right-click" the attachment and select "Save link as".  Save in it "C:/RoboDK/Posts" For the image, follow these steps.  1- C...
17 Replies 6,929 Views
Thread: Function for automatic "Get Position" when running a program on robot
Post: Function for automatic "Get Position" when running...
Hi Guys We are running all our programs on the robot from RoboDK. Before we right-click the program to click RUN, we have to remember to first select "Get Position" on Robot Connections screen. The ...
11 Replies 4,009 Views
Thread: Default PTP speed too fast
Post: RE: Default PTP speed too fast
Hello Jeremy, Thanks for the Post file attached. However, I feel a bit foolish - please bear with me! When I click on the file which you have attached to download it, a link is opened as per the atta...
17 Replies 6,929 Views
Thread: RoboDk connected to robot but only runs sub-programs but not main prog
Post: RE: RoboDk connected to robot but only runs sub-pr...
Hi All,  I have found the solution. In order to run a main program with program calls on the robot directly by RoboDK, you first have to right click each program called by the main program and select...
5 Replies 2,216 Views
Thread: Default PTP speed too fast
Post: RE: Default PTP speed too fast
(12-03-2020, 04:11 AM)Jeremy Wrote: Hi Curt,  I now have a solution for you.  The PTP speed is actually hardcoded in the post-processor.  We modified the post-processor to expose the porting contro...
17 Replies 6,929 Views
Thread: Default PTP speed too fast
Post: RE: Default PTP speed too fast
(11-30-2020, 08:26 PM)Jeremy Wrote: Hi Curt,  To modify the speed of the first PTP motion, you need to "Right-click" the generated program -> "Show instruction" -> Find the first "SetSpeed" (...
17 Replies 6,929 Views
Thread: Default PTP speed too fast
Post: RE: Default PTP speed too fast
Hi Jeremy, Note that all my programs are created from DXF drawings through DXF2Gcode. I have noticed set in the generated program that the default speeds just before the PTP move (Program Start) and ...
17 Replies 6,929 Views
Thread: IO Outputs not activated when running robot with RoboDK
Post: IO Outputs not activated when running robot with R...
Hi Jeremy, I am currently connecting RoboDk to my KUKA KRC-2 and running the robot directly from my laptop using RoboDK, but I am switching on the coolant and blade motor manually from an external sw...
3 Replies 1,817 Views
Thread: Default PTP speed too fast
Post: Default PTP speed too fast
Hi Jeremy, I am running a Kuka robot directly with RoboDk. The first PTP move of every program is moving the robot dangerously fast! I also need to limit the LIN speed and CIRC speed in the default....
17 Replies 6,929 Views
Thread: RoboDk connected to robot but only runs sub-programs but not main prog
Post: RE: RoboDk connected to robot but only runs sub-pr...
(11-27-2020, 01:39 PM)Jeremy Wrote: Hi Curt, Seems like there's an issue with the attachment. Jeremy Hi Jeremy Sorry about that, I have attached my station now. Note that when I connect to the ...
5 Replies 2,216 Views
Thread: RoboDk connected to robot but only runs sub-programs but not main prog
Post: RoboDk connected to robot but only runs sub-progra...
Hi, I have connected RoboDK to a Kuka KR210 - L150 robot . I selected Run on robot and then Run after right-clicking a program. RoboDk moves the robot when running an individual program but not when a...
5 Replies 2,216 Views
Thread: Semicolon rejected in LAYER name in CAD for use in Dxf2gcode
Post: Semicolon rejected in LAYER name in CAD for use in...
Hi guys, I tried to use the MILL prefix in the layer in the layer name in my "master" CAD Software dxf file as follows:  MILL: 1 Md: -23 Sd: -23 F: 400 Fz: 400 Sm: 10 T: 1 Td: 5 . However, my CAD soft...
1 Replies 2,290 Views
Thread: Circular Blade Not Lifting before turning to cut next toolpath for DXF
Post: RE: Circular Blade Not Lifting before turning to c...
Thanks, the advice helped a lot! Another question though: When using the MILL prefix a tool number can be selected in the layer name which is then used in the gcode. In RoboDK station we have 3x tool...
5 Replies 4,078 Views
Thread: Circular Blade Not Lifting before turning to cut next toolpath for DXF
Post: RE: Circular Blade Not Lifting before turning to c...
Thanks Albert, I have shared the RDK file. However, I get an error message that the "Type of File that you attached is not allowed". The DXF file was created on Autocad 2007 and export as Autocad 200...
5 Replies 4,078 Views
Thread: Circular Blade Not Lifting before turning to cut next toolpath for DXF
Post: Circular Blade Not Lifting before turning to cut n...
Hi Guys, I am new to RoboDK. I have created 3 TCP on one tool attachment namely Waterjet TCP, Router TCP and a Circular Blade TCP and selected "Tool Orientation follows path" under TCP Settings for t...
5 Replies 4,078 Views