Options Menu

Options Menu

Select ToolsOptions Menu - Image 1 Options (Shift+O) to open the main window of RoboDK settings.

Most of the settings are stored in the computer’s user account. Changing the user account will not keep the changes applied in these options. As an exception, the Station settings and the station parameters (available in the General tab) are stored with each Station (RDK file).

Tip: Select Set default settings to revert any changes to their original/default values.

Note: The license settings are available from the menu Help➔License and these settings are stored in the System, so the same license is applied to all the users of the same computer.

General tab

The Default Euler angles mode allows selecting the order in which frame rotations are done by default. A generic reference frame contains position and orientation information. Reference frames are poses and they can be represented using XYZ position and rotations around X, Y and Z. The order of rotation is very important. RoboDK will pre-select the right format/order depending on the robot that is used. See the reference frames section for more information.

The Default left click action is set to select objects by default. It is possible to change it to other 3D navigation settings, for example, to rotate by default.

With the Mouse 3D Navigation style, it is possible to specify the preferred type of 3D navigation with a mouse and emulate specific software, such as Rhinoceros, Catia, TopSolid or Vero software.

The Robot panel type is set to Complete by default. This will display a complete robot panel. Set this option to Normal or Basic to reduce the number of options available in the robot panel.

System’s Locale allows setting the locale to a specific language and country. This will display the numbers in the right format and use the appropriate decimal point character.

Object/Target/Path/Other reference size will define the size of the frames on the screen for specific items. It is recommended to use the keys + and – instead to grow or shrink the sizes proportionally.

The Display tree preference will display the station tree inside the main window by default. Change it to Side Window to display the tree as a separate window.

It is possible to Clear the Undo Stack to clear the RAM memory. It is also possible to limit the Undo/Redo actions that will be kept in memory. If RoboDK slows down it could be because there is a lot of undo actions being stored. By default, similar actions are not grouped together, for example, if a reference frame is moved, every small step will be recorded. Check Bundle similar actions together to avoid this behavior.

The Text/icon size section allows changing the size of the text and icons in the tree and the toolbar.

Tip: From the main screen, hold Ctrl and move the mouse wheel to change these values gradually while having a visual feedback of the result.

The Maximum distance to attach an object to a robot tool is used by a simulation event. Simulation events can attach objects to tools and simulate specific events. These events have no impact on generated code, they are only used for simulation purposes.

The Station parameters are state parameters that are saved with the RDK file and can be modified manually or through the API. The Station parameters allow simulating Digital Inputs and Digital Outputs and communicate the simulation with other systems through the API such as a PLC.

Note: The Station settings are parameters that are stored with the active Station. Changing the Active Station will update these values. Also, modifying these values and saving the RDK file will update the Station Settings on the RDK file.

Options Menu - Image 2

Display tab

Select the colored button beside the Collision color, Selected color, Text color or Points color to change the default colors used in the main screen.

Select Display XYZ axes letters to display the reference frames with the corresponding X, Y, Z letters. By default, they are not displayed and the standard Red (X), Green (Y), Blue (Z) colors are used.

Increase the Pick curve/point sensibility to make it easier to select curves and points respectively. Alternatively, if curves or points are too close to each other and it is not easy to select them it is better to reduce these values.

Arrow size (curve/point) is the size of the green arrows displayed in curve or point follow projects (available from the Utilities menu).

The reference frame colors can be updated as well as the gradient background colors manually (the plane colors are displayed when moving reference frames with the mouse).

The Camera view is set to Perspective by default. It is possible to change it to Orthographic and update some camera settings such as the View angle and the Near/Far planes.

Uncheck Keep rotation aligned to freely rotate in any direction.

By default the display settings are set to obtain the Best Quality results. Set the Display Performance to Best Performance if RoboDK slows down because there are too many objects being displayed. This will force using the GUP and not display small objects in the screen.

It is possible to use a 3D Connexion mouse, such as the SpaceNavigator and change the default translation and rotation speeds using that mouse.

It is also possible to display RoboDK on a 3D screen (use 3D view for Virtual Reality). The Stereo camera distance will define how close or far the objects feel.

Options Menu - Image 3

Motion tab

The Simulation time ratio defines how fast the simulation happens with respect to the real time. A default simulation ratio of 5 means that 1 second spent on the simulator equals to 5 seconds in real time running on the robot. More information available in the Simulation ratio section.

Tip: The simulation can be accelerated by selecting Program➔Options Menu - Image 4 Fast Simulation or holding the space bar.

Options Menu - Image 5 Check collisions and the Options Menu - Image 6 Collision map allow activating/deactivating collision checking. These settings can also be changed from the tool bar or the Tools menu. By default, all programs and moving robots will be stopped if a collision is detected, uncheck Stop robot movements when a collision is detected to avoid this behavior. More information about collision map settings in the Collision tips section.

Move time calculation defines how RoboDK calculates the cycle time and how the robots use the linear/angular speeds/accelerations for simulation and timing. More information available in the Cycle Time section.

If the simulation ratio is too fast the computer might not be able to display the robot at the end of each path to keep a fast simulation. To avoid this effect: check Always display robots at the end of each movement.

The Maximum path step (mm/deg) defines how RoboDK discretizes any linear and joint movements respectively for simulation purposes.

The Threshold angle to avoid singularity for joint 5 (deg) is used for 6-axis robots to avoid the wrist singularity. If a singularity is detected, the robot program must be changed to make sure the program will properly run on the real controller.

The Robot drivers sections allow specifying the behavior of robot drivers. Robot drivers allow having a permanent link between the real robot and RoboDK.

Manage I/O with RoboDK when connected to a robot will simulate Inputs and Outputs as RoboDK Station Parameters instead of altering the state of Inputs/Outputs on the robot.

The option Show robot feedback in RoboDK when connected to a robot will display the robot movement in real time as the robot moves.

Show a warning message before running programs directly from the PC will show a popup window before the program is executed from the PC (when using the Start on Robot option).

Uncheck Never force stopping a subprocess started by RoboDK if you experience problems with robot drivers. This will make sure that no other processes are running behind the scenes when a new connection is set.

Options Menu - Image 7

CAD tab

The CAD section (Computer-aided design) allows specifying all the settings related to importing parametric files (STEP/STP and IGES/IGS) and displaying these files in the 3D environment.

Tip: Select Fast import settings if importing 3D files takes longer than usual.

Options Menu - Image 8

Increase the Linear/Angular accuracy of the surface to import files faster. Decrease these values to improve the accuracy of the imported objects.

If we are using a curve or point follow project (from the Utilities menu) and we are using the Fast import settings it won’t be possible to select curves included in these types of parametric files. In that case, check the option Import all curves and points.

The Curve accuracy defines how accurate curves are imported from parametric files. By default RoboDK will import all curves included in these files. Furthermore, RoboDK will extract the edges of curves in the 3D files.

It is possible to automatically generate a zig-zag curve from each surface and specify the step between passes and how far the curve is kept from the border. This might be useful for painting or inspection applications.

More tips about these settings available in the Import STEP/IGES section.

CAM tab

The CAM section (computer-aided manufacturing) contains all the options related to manufacturing operations typically done by machine tools (CNC) and how to import toolpaths created using CAM software.

The Operation speed is the default speed used in operations for curve and point follow projects, available from the Utilities menu.

The Approach distance for points is the default distance used to approach to points in a point follow project. This option is useful for drilling or spot welding.

Include a normal approach/retract by default will include a 100 mm normal approach to the toolpath.

It is possible to ignore the Go Home command (G28 ISO code) set by specific milling programs, or set it to a specific value as XYZ coordinates.

The Program events defines what actions are taken for specific G-code events, such as setting digital outputs, managing extruder heads or triggering specific programs at different stages of the manufacturing operation.

Other options are available to define the default settings when a new robot machining project is started. These are the same settings available from the robot machining menu.

The Quick path preview section allows setting how many tools are displayed as a preview when moving the reference frame or the tool frame of a manufacturing operation.

It is possible to open the 3D printing options of the Slicer from the 3D printing section. A Slicer splits an object into a machine toolpath, then, the toolpath can be easily converted to a robot program with RoboDK.

Robot programs generated from CAM programs can be modified after they have been generated. However, updating the settings from the robot machining menu will override any previously generated program. Check Never override edited programs generated from CAM projects to avoid losing any changes.

The Length of the displayed path normals (mm) is the length of the white vector representing the normal of the CAM toolpath. The CAM toolpath is displayed in green.

Options Menu - Image 9

Accuracy tab

The Max digits and Max decimals represent how many digits/decimals are displayed before the decimal point and after the decimal point respectively, for robot joint targets in the graphical user interface.

The Accuracy tab shows specific options related to Robot calibration and Ballbar testing.

Options Menu - Image 10

Program tab

The Program tab shows the settings related to programs.

Checking Update program paths when the station is loaded will update any program issues and display the programs that have issues with a warning sign: Options Menu - Image 11. It has the same effect as right clicking each program and selecting Validate Path. Uncheck this option to load programs faster. This option skips long programs (more than 1000 instructions).

Checking Hide program path by default will not display the program paths when new programs are generated. Right click a program and check/uncheck Display path respectively to show/hide the yellow path of the robot TCP.

Use Tool/Frame numbers for numbered Tools/Frames will use the corresponding register numbers of a tool/reference frame instead of updating the tool and reference frame poses on the robot controller. This is available for robot controllers that mostly use numbered registers instead of variables. This behavior can also be customized using post processors.

It is possible to force a specific target Output for joint/linear movements on program generation, by imposing joint or Cartesian data. By default, RoboDK will use the target settings (joint coordinates for joint targets and Cartesian coordinates for Cartesian targets).

By default, RoboDK will create new targets as Cartesian targets, that means that if a reference frame is moved, the position of the robot to reach that target will be different. It is possible to select Joint targets to impose absolute targets that do not change depending on the reference/tool changes.

Select Skip program calls that don’t exist in the station to ignore generating programs.

Tip: Skip speed changes in programs allows to quickly simulate and generate dry run programs that are supposed to take a long time to execute.

When a reference frame is used in a program (using the Set Reference Frame instruction) and that reference is moved afterwards, the robot movement is altered. By default, the set reference frame instruction will place the robot reference at the original location without altering the station reference.

Note: This setting only applies to automatically generated programs (such as milling programs).

Tip: It is common to create a program that uses a specific reference frame. If the reference frame is moved and the program is re-executed it is possible to use the updated reference frame by setting this setting to Always update the station. In that case, it is not guaranteed that the program will be feasible the same way it was originally created.

Limit the maximum number of lines per program can be checked to specify how many lines a program will have at most. This will split a long program in sub programs and will generate a main program that runs these smaller programs sequentially. Robot controllers have limited capacity and can run programs of a certain size. Except for specific/older robot controllers, most controllers can handle 5000 lines in one program.

Finally, specific settings are available for specific robot brands when using built in post processors. On the other hand, custom post processors allow customizing or imposing certain behavior right before the program is generated.

Options Menu - Image 12

 

Other tab

The Other tab shows settings related to the RoboDK API, the Python API and other specific settings.

Select Set default Python settings to see the Python settings displayed in the next image. This will suggest updating the Python API for RoboDK if it has not been updated. The Python API for RoboDK are two files located in the Python folder (robolink.py and robodk.py).

By default, RoboDK will save the RDK station every time a script is saved. Uncheck Auto save station when Python script is saved to not save the RDK file.

It is recommended to install FileZilla Client to transfer robot programs from the computer directly to the robot if they are both connected in the same network.

It is also recommended to use Notepad++ in Windows to view or touch up programs or robot Post Processors. Otherwise, RoboDK will use Scintilla and the Python IDLE by default.

It is possible to allow external communication of the RoboDK API by checking Allow external API and selecting an appropriate server IP and port.

Select Proxy settings to use a Proxy server when using Network licenses or connecting to the online library.

Options Menu - Image 13