Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Adjust the Head Direction to cut with Blade
#1
hello everyone,
I have a small problem in the project I am running on RoboDK.
I extracted the apt files from a CAM and imported to RoboDK, when I go to adjust the axes by optimizing the motions with the linear track I get a motion that is not good for lunging with the 45° disk, it rotates as it goes to sink the material plate and I don't want it to do that, I want it to position correctly from the start and enter the material with the correct head position.
I've tried changing the values in "Preferred joints for the start point" and this movement goes and corrects it for me, but then I have problems with the circular cut of the right-most template...

Can you give me advice on how to set the parameters correctly for this case?
Also, is there a method to change the default parameters of the machining project settings? I would like to always have axis optimization active, without always having to activate it manually.

Thanks, attached project and image of the incorrect motion.


Attached Files Thumbnail(s)
   

.rdk   Project Cut Slab.rdk (Size: 3.16 MB / Downloads: 39)
#2
I suggest you put the Z of the tool "Tool 31" pointing downward, that way you will have more control over the curve follow project settings.

The APT file might need to be re-imported to RoboDK in order to adjust the normal of the curve upward to fit the new tool Z orientation.
You can then select the algorithm "Tool orientation follows path" to force the tool orientation correctly on path.


Attached Files Thumbnail(s)
           
#3
Thanks for the quick response, i have tried with your tips to set up the robot machining but i don't obtain a good result. See image attached.
I have the robot Head and the disk completely in a wrong direction if i change the Z direction of the tool.
Did you have tried and you have obtained a good result in your test?
If yes can i see your project? maybe i miss something or i have different setting i don't know.
Thx


Attached Files Thumbnail(s)
   
#4
It is important that the normal of the curve point upward in order to correctly set the curve follow project.

Can you modify the APT file to have its normal pointing up ?


Attached Files Thumbnail(s)
   
  




Users browsing this thread:
1 Guest(s)