Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Avoid Arcs / lead-in

Hello guys,

I have a problem with converting Arcs to Linear Movements. Your suggestion from this post has already been implemented (Avoid Arcs: min arc length: 0.5mm, max arc length: 0.2mm).

When I start a CNC Project (GCode) with G01, G02, G03 commands, the lead-in command (5 or 3mm arc) is never transferred correctly to a LIN Movement but remains a CIRC Movement instead! This is insofar a problem that the blending of Points (CDIS) generates imperfect circles because the robot deviates too early from the given patch. I am certain that he would not do that, if he would translate the first lead-in correctly into a few linear movements. I have experimented with the arc length settings, but can´t change the lead-ins (and somehow only the lead-ins).

Attached you will find several files.
1. An exemplary cut of a copper sheet, where the lead in deviates too early so that the whole circular contour is not closed.
2. Excerpt of the GCode.
3. Excerpt of the generated kuka code
4. Screenshot of the robot program
5. The "avoid arcs" settings
6. The actual RoboDK file


Attached Files Thumbnail(s)

.rdk   Laser_Cutting_1.rdk (Size: 6.7 MB / Downloads: 247)
You are right, arcs are not properly split into small linear movements. We'll get back to you with an update. This may take 1 or 2 weeks.
We just fixed this issue for Windows versions of RoboDK:

You should now see all circular/arc movements properly converted to small linear movements.
Great to hear....I will give it a try.
Thank you Albert

Users browsing this thread:
1 Guest(s)