Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can not import curves
#1
Hi, on both Windows and Linux with version 3.8.4 I can not import an exported curves file which I also created with 3.8.4. I attached the file.


Attached Files
.zip   Curves.csv.zip (Size: 450 bytes / Downloads: 31)
#2
I forgot to mention the error message. It is "No curve found (only text format is accepted)"
#3
You should remove the text from the last column. I can see you have the keyword "Kurve" in some rows.
#4
This is strange, because I didn't put those keywords there.
What I did was
1. opened the part in SolidWorks 2017 and exported the curves via RoboDK Plugin with "Load curves"
2. in RoboDK selected "Export curves" on the imported object in the tree view

I tried to delete those columns and reimport the curves in LibreOffice, but it seems tricky. LibreOffice always messes with my regional settings. After setting RoboDK and LibreOffice to decimal point instead of comma and deleting those strange columns, at least I can see most of the curves (and also some new ones). I will try to delete those columns in a text editor next time and hope that'll work.
#5
I did exactly that manually using Excel last week and it worked perfectly.
But after removing the curve name column, I also need to reorder some of the rows so that the curve follows a straight path when going from one curve to the other.
In other words, some exported curves were exported backward, so I needed to switch their sense. Using the "Sort" tool from Excel, it was pretty simple.

Have a great day.
Jeremy
#6
I don't get it.
I opened the curves file with a text editor and removed all "Curve," keywords. Still can't import with the same error message as mentioned above. After removing the numbered column on the right of the curve column RoboDK imports the file, but I get additional curves. As I understand the odd numbered rows are the start points and the even numbered rows are the endpoints, right? If so, then the import should work fine, because my point tupels are looking fine.

I have also another problem when changing the normals with "Tilt curve normals". To me it seems like random behaviour how and in which direction the tilt moves. When I tilt a curve by 20 degrees and then try to tilt it by -20 degrees back, it sometimes tilts in the same direction as before. Also is it possible to reset the normal to an absolute value? After changing a normal it's impossible to me to reset the normal to the point it was before.

On Windows 10 I also can't see the normals of the curves when I hover over the curves with my mouse, whilst on Linux it does on the same project. I checked some settings but they are quite at the initial state on both machines and seem equal.
#7
Hi can you send me your .csv file with your curve in it.

Jeremy
#8
I attached three files:
1. Curves.csv is the created file after exporting from SolidWorks to RoboDK and from RoboDK to file
2. Curves_modified.csv is where I removed the Curve and the numbered column
3. a RoboDK project with the correctly imported curves from SolidWorks, simply named curves (that is what it should look like) and the curves imported from the file Curves_modified.csv, named curves_modified.


Attached Files
.zip   import_curves_test.zip (Size: 1.6 KB / Downloads: 38)
#9
I just looked at your .csv file.
I was right in my first message.

Your start and end point are inverted in the .csv file. Considering that, RDK add some extra lines that it thinks are needed.
If you reorder your point correctly, it should works.

If you look at your .csv file, the lines 1 and 4 are the same, therefore they should be one beside the other, if not it will create a back-and-forth movement like you are experiencing right now.

Have a great day.
Jeremy
#10
Thank you, it worked. But still it seems to be different, because when I hover over the curve with my mouse the normals of all curves are shown and they are also oriented in the inverse direction.

Also why does it bother RDK that lines 1 and 4 are equal? After rearranging the lines 1 and 16 match now. Is it planned that the export/import work flawless in the future or is there a reason for these manual steps?
  




Users browsing this thread:
1 Guest(s)