Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot connect to UR10
#1
Hello

So, I have a UR10 that runs Polyscope 1.8.25319 (Oct 19 2016) on an UR CB2 controller.

I would like to connect to it trough RoboDK, but it seems to not work.
I have no problem pinging it.
From the log it looks like it is connected, but the status keep being "Waiting..."  

The log can be seen below: 

CONNECT 192.168.87.105 30000 6
Closing previous connection...
Available local IP addresses (IPv4):
192.168.56.1
192.168.192.1
192.168.152.1
192.168.87.101
Server established: 192.168.87.101:30000
Connected to 192.168.87.105:30002. Sending program :/progrobodk.script...
Updating computer IP on program: 192.168.87.101
Updating computer port on program: 30000
Program sent.
Waiting...

 
I have also tested a UR5 with a CB3 controller, which was not a problem.

Anyone know what could be wrong? Does RoboDK not support the CB2 controller or the version of Polyscope?

Best regards.
Kaj Mork
#2
Hi Kaj,

If you take a look at the log window of the UR teach pendant you probably see one or more non supported function calls that are related to newer controllers.

You should follow these steps to change the controller version variable to 3:
https://robodk.com/forum/Thread-UR-Run-o...732#pid732

Albert
#3
Hi Albert.

I have followed the steps in the link and changed the controller version to 3, but the end result is still the same.
Disconnected
Stopped
Starting robot driver: C:/RoboDK/api/robot/apiur.exe
Starting...
RoboDK driver for UR v3.9.0
Loading settings: C:/Users/kajmo/AppData/Roaming/RoboDK-Drivers/apiur.exe.ini
MoveJ with Joints: Yes
MoveL with Joints: Yes
MoveL as: movel(...)
Controller Version: 3
Communication Timeout (ms): 1000
Disconnected
Sending command...
Available local IP addresses (IPv4):
192.168.56.1
192.168.192.1
192.168.152.1
192.168.87.101
Server established: 192.168.87.101:30000
Connected to 192.168.87.105:30002. Sending program :/progrobodk.script...
Updating computer IP on program: 192.168.87.101
Updating computer port on program: 30000
Program sent.
Waiting...


I also looked at the log window of the UR tech pendant, but can´t see any of the non supported function calls that you mentioned:
******** Log end (2021-10-21 14:41:05) ********
******** Log start (2021-10-21 14:42:43) ********
T 0000d06h17m40.232s PolyScope PolyScope 1.8.25319 (Oct 19 2016)
T 0000d08h04m58.232s PolyScope Connected to Controller
V 0000d08h04m58.232s URControl URControl 1.8.25319 (Oct 19 2016)
R 0000d08h04m36.256s URControl C101A0: Real Robot Connected
R 0000d08h04m36.264s URControl C100A3: Robot changed mode: INITIALIZING
R 0000d08h04m36.272s SafetySys C69A0: End of startup messages from Masterboard to Controller
R 0000d08h04m43.184s SafetySys C72A2: Starting UR10
R 0000d08h04m43.192s SafetySys2 C72A2: Starting UR10
R 0000d08h04m43.384s URControl C100A5: Robot changed mode: EMERGENCY STOPPED
R 0000d08h04m43.432s URControl C100A7: Robot changed mode: ROBOT POWER OFF
T 0000d08h04m36.256s RTMachine ''
T 0000d08h05m05.064s RTMachine Cannot drive robot, program stopped
R 0000d08h05m08.232s URControl C100A3: Robot changed mode: INITIALIZING
R 0000d08h06m01.408s URControl C100A0: Robot changed mode: OK
  




Users browsing this thread:
1 Guest(s)