Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Communication error Yaskawa HC10 (YRC1000)
#1
Hi,

I am trying to connect an Yaskawa HC10 with an yrc1000 controller to robodk but it does not work properly. It does ping and connect, but as I try to either get its position or move it gets connection errors and says unknown state. I have attached a screenshot including the log. 

I have seen similar threads and tried disabling the firewall and other tricks without any luck. 

Best regards,
Jonas


Attached Files Thumbnail(s)
   
#2
Hi Jonas,

Can you try with the latest version of RoboDK and the MotomanHSE driver? This should be the default driver for Motoman robots.

Albert
#3
I am facing same issue. Controller is yrc1000 and robot is gp12.
I am using motomanhse driver. 
I am able to ping and also able to get position.
But when i try to move joints, the log keeps showing 'Select REMOTE mode on the pendant ' whereas the key is already on remote.
I also tried to turn on the servo in play mode and then turm to remote but still the same.
The explore option, the send program to robot option also donot work.
Please help.
In a nutshell, i am just able to get position, the soft robot copies the postion of the actual robot
#4
Please make sure you are using the latest driver for Motoman called MotomanHSE

See attached image.

For some reason we missed to attach this driver for some versions in the past. If you update RoboDK you should see this driver.

   
#5
Hi,

I have updated Robodk to the latest 5.02 version on Windows and still i am facing the same issue.
Both the drivers are present : MotomanHSE and MotomanDataSHE.

I get the ping, when i connect the bar turns green and says "ready"
clicking on Get position,, makes the Soft robot copy the pose of the Physical Robot perfectly. And the Log show some "CJNT" instruction
But when i try to move the robot (I have made a dummy program of just 3 targets and i click run on Robot) the soft robot only moves. the Actual Robot doesnot (and in the log there is an erro "Turn key to REMOTE"). The key is already on Remote. I even tried to turn the SERVO ON in Play mode and then turn the key to remote mode. But same issue persists. Please let me know what else can i do. OR if you need any more information to help me troubleshoot, i can get it as i have the Demo Robot (YRC1000, GP12) for R&D purpose
  




Users browsing this thread:
1 Guest(s)