Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect RoboDK on Windows to KRC4 via ethernet
#1
Hi,

I am trying to link via ethernet my Dell XPS 15 to my KRC4 controller, smartPAD, and kr30-3. 

I have been through the Connect-KUKA-robots-with-RoboDK.pdf setup instructions , gotten a 'succesful' ping message from the RoboDK UI with the robot IP but cannot connect.

Moving on to the troubleshooting section...

Here is the output when I ping the robot from a shell:


Code:
Pinging 172.31.1.147 with 32 bytes of data:
Reply from 172.31.1.142: Destination host unreachable.
Reply from 172.31.1.142: Destination host unreachable.
Reply from 172.31.1.142: Destination host unreachable.
Reply from 172.31.1.142: Destination host unreachable.

Ping statistics for 172.31.1.147:
   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

I have set my IP address to 172.31.1.142, which only has the last digit different from the robot, so should be on the same network

Where I am currently stuck is with testing the robot driver. After being prompted to install numerous .dll filles, as well as vcredist...exe, I still get two errors when opening either apikuka.exe or apirobot.exe in C:\RoboDK\api\Robot.

I have attached relevant screenshots.

Any help would be great!

Ash

           
#2
To update, I have solved the ping issue - I had the ethernet cable in the wrong port.. moving it to the port labelled KLI seems to have sorted it.


Still working on the screenshot errors

Having a similar problem on mac:

Unexpected error: dyld: Library not loaded: @rpath/QtNetwork.framework/Versions/5/QtNetwork
#3
I recommend you to update RoboDK for Windows and for Mac to the latest version (published last Monday).
The Mac version properly includes drivers to all robots supported in the Windows version.

Let me know if it does not fix the popup issue that you sent.
#4
Thanks for info - Will update mac version

Already running 3.4.6 on windows
#5
Still no luck with either mac or windows unfortunately
#6
After lots of deleting and re-downloading .dll files I finally resorted to reinstalling windows on my computer.

It's now working!!

I guess some of the .dll files went missing or got corrupted during my last OS install
  




Users browsing this thread:
2 Guest(s)