Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Connection Issue with Dobot CR5 robot


I have some issue with connection to Dobot CR5 robot. I am not able to communicate with the real robot. Strange thing is that I am getting Device name as some random string every time. After waiting for some time,I am getting the connection status as "Ready". But I am not able to move the robot or do anything. And If I try to do something the Connection window is stuck with "Working" status. 

I am attaching another screenshot(dobot3.png) which was taken from a different pc. There the device name is different. And after sometime the Connection Status goes to "Ready" and then I wont be able to do anything as it will be stuck with "Working" Status.

I am using the latest robodk version(5.6.0 64 bit). I have tried port 2000 as it was default port that appiered in robodk when I added the robot and port 22000 as i found dobot studio pro is communicating to robot with this port using wireshark. Both didnt worked.

Can anyone help? Thanks.

Attached Files Thumbnail(s)
edit: I have uploaded dobot4.png screenshot which says I need to reinstall robodk (I double clicked the DobotDriver.exe). Is this really an error or am I not supposed to run it by double clicking it like this?

Attached Files Thumbnail(s)
We'll be publishing a new update in the next 2 weeks that improves our integration with Dobot CR series. I sent you an email so you can use the new version of the post processor and driver before the update.

Users browsing this thread:
1 Guest(s)