Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Controlling UR Tool I/O
#1
Hi all, 

I have a UR10e that I have connected to RoboDK and can successfully run programs off of. I am currently exploring the ability to use RoboDK's GUI to do online programming and am running into an issue when controlling the I/Os. 

If I want to set the I/Os on the controller, the GUI I/O button works fine (Digital Outs Named IO_0 thru IO_7 in RoboDK map correctly to the URs DO0 thru DO7 for example). However, to control the Tool I/O I am running into issues where I am not able to trigger them through this same command. 

Looking into the polyscope commands, I discovered that "set_standard_digital_out" controls the controllers digital outputs while "set_tool_digital_out" set the tools digital outputs. My first thought was to just inject this code into the tree through the "insert code" instruction, but I found out through this thread that this is not a supported feature. 

https://robodk.com/forum/Thread-Insert-i...rsal+Robot

Am I overlooking something, like maybe just calling the IO by the wrong name? (UR documentation indicates it is called TO0, TO1, but I have also tried IO_8) Or is there no way to control the UR Tool I/Os through GUI commands? 

   

Thanks in advance! 
Trevor
#2
Hi, I am having the same issue with my robot, an ur3e and a tool that takes objects!!

Did you solve the problem?
#3
Tool IOs are mapped from ids 10 and up. For example, DO 1 on the tool should be DO 11 in RoboDK.

Also, make sure you modify the apiur.exe.ini file and set the CONTROLLER_VERSION variable to 5.

More information here:
https://robodk.com/forum/Thread-UR-Run-o...732#pid732
#4
Hi Albert, 

The solution worked great! Thank you for the technical support!
#5
I solved the problem with your response!! thanks a lot!!
  




Users browsing this thread:
1 Guest(s)