Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Curve Follow Project Bug
#1
Hey there,

now on our 30 day trial to test out this tool.

Having difficulties with the Curve Follow Project, it seems to not allow me to select all of the possible curves once one is selected.
Meaning I try to add curve for this part for instance, it splits it in two (how can I make it into one without two curve project instances?) and before I actually select the half curve part, I can see both options when hovering over them.

Once I select one, the other options are no longer available - not if I want to re-select my curves or add a new curve project. It seems to break that specific part.

I can see all other curve options for other parts.

And if I delete all of my curve project and try again , it somehow saves my preselected curves and does not allow me to select any other on that part.

[Image: 3Hu32jG.png]
[Image: D6busob.png]
[Image: 0tllUZd.png]
#2
Hi Karli,

This is because, for some reason, both the curves are on different objects.
You can either "Right-click" the curve and "delete" curve (do that for both and re-extract the curves) or you can merge both objects by selecting them both -> "Right-click" -> "Merge".

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Hi Jeremi,
thanks for the swift reply.

It doesn't import as two objects, but seems to split the top surface into 2 curves.
And once I have created one Path Follow project for one half, I can't select the other half at all, until I have deleted the first selected half - meaning I can only do half of the circle/stadium shape path.

I see I can open the three of points, if there is a way to mirror the points I could maybe just do that?

UPDATE
found the issue to be the CAD, forgot that this part is injection molded, thus has taper.

Yet still would like to be able to select all possible curve on the object once one is selected.
#4
Any tips on hiding the XYZ when running the actual paths?
Can seem to find the option to hide it.
It is hidden for the bodies themselves, but shows up whenever the path is run.

[Image: k31STM4.png]
#5
Hi Karli,

Right-click the tool and select "visible TCP".

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#6
(12-10-2020, 02:52 PM)Jeremy Wrote: Hi Karli,

Right-click the tool and select "visible TCP".

Jeremy

It's not the tools TCP, it's the paths generated using the Follow Path tool.
[Image: sA7h2Bg.png]

but I managed to hide it using - and +
#7
Oh, sorry.

Then you can change the size either by using the + or - key as you did or
"Tools"->"Options"->"Display"->"Arrow size"

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#8
Hey there,

so I finally had some time to work on this project again.

And the issue I am facing is that the robot follows my curve projects nicely in real life if played via RoboDK software.
Once I send the program to the robot, it tends to try and go through it-self.

This was also an issue with simple waypoints, but I figured if I reference all waypoints from the base, it tends to fix things, yet does not have any impact for the curve follow project.

Also noted is the fact that my custom code inserts only work if the program is sent to the robot, which makes sense.

I tried to open path with "Show Instructions" to manually cycle through the moves, and it works fine as long as I don't send the path programm to the robot.
Also manually changing the reference to my custom reference frame, or robot base or anything else yields no changes.

When clicking on select targets to see the targets it tends to randomly place all of them not far from base, which ofcourse is not where they should be.
Again, changing the reference frames or support of targets changes nothing.

Any ideas?

[Image: dTC5sTS.png]
[Image: KJrsFdt.png]

[Image: U5YBiWy.png]

Also another question, I know you can create start/stop arcs that are both normal to the surface or normal to the base (keeps tool perpendicular to base, not path)
Is there an option to do the same with the path created by curve follow project? So to keep the tool normal to base not the path?

We have to dispense on small parts with quite sharp curves and with the setting now, the tool tends to swing a lot, which is not prefered in terms of safety.

You mention it here
https://youtu.be/oW2Pxz4RoYc?t=1958
#9
Link to video
https://photos.app.goo.gl/XZKydCKtfkTvtJAL7
#10
Hi Karlisaki,

Can you update RDK to the latest version and see if it fixes the issue? We fixed a similar issue not so long ago.
Otherwise, can you provide the .rdk file, please? I would like to look at something.
Last thing, did you try the "Generate robot program" and load the program manually on the controller using a USB stick? Do you end up with the same result?

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)