Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Default PTP speed too fast
#11
(12-08-2020, 03:20 PM)Jeremy Wrote: Hi Curt, 


You should be able to "right-click" the attachment and select "Save link as". 
Save in it "C:/RoboDK/Posts"


For the image, follow these steps. 
1- Choose files
2- Add attachment
3- click where you want to image
4- Insert into post 

 Jeremy,

I have saved the post attachment in "C:/RoboDK/Posts". Then changed lines 93 & 94 as per your instructions to change from KRC-4 to KRC-2. I then double-clicked the robot in the tree and then clicked Parameters where I selected the "KUKA_KRC4_Slow" post. I then ran a simple "single move" program on the robot from RoboDK. The first move to the Path Start was still crazy fast. 
   

I am beginning to think that there is something wrong with my program missing a first target before moving to the Path Start?? Please can you check the simple program which I tried to run.
   

I have attached the RoboDK station and the NGC file. Please can you check to see if you can find a problem?

I have also attached a short video of the actual robot's first move. 

Kind regards
Curt


Attached Files
.rdk   Kuka KR210 L150 -2 Testing Fast Move Jeremy Post Processor.rdk (Size: 11.05 MB / Downloads: 22)
#12
    Hi Jeremy

Thank you for your patience! I have copied your KUKA_KRC4_Slow post as per insert below.

   

I then changed the script to activate KRC2 as script insert below:

   

I then created a small move on a DXF drawing to the furthest X and Y position on the worktable which is the furthest point form the Robot home position. This was done to test the speed and momentum of the move to PATH START. I have attached the DXF drawing. See insert of drawing below.
   

I then clicked "Edit Path Manually" in RoboDk and the exported the Shape from DXF2Gcode which I then copied into my RoboDK station. See insert of NGC file created below:
   

I then changed selected the KUKA_KRC4_Slow post in Robot Parameters, connected to the Robot and ran the program. Unfortunately, the first move was not any slower. 

Please can you check the RoboDK file which I have attached below to see if you can see what I am doing wrong.

Kind regards
Curt


Attached Files
.rdk   Kuka KR210 L150 -2 Testing Fast Move Jeremy Post Processor.rdk (Size: 11.05 MB / Downloads: 26)
#13
Hi Curt,

Sorry for the delay, I forgot to answer this one.
Looking at the second print screen of your Dec 11th post, lines 20 and 21, we see that the PTP speed is now 20%.
That should be good enough for it to work.
Does anything else override this command?
Can you manually change these values to see if it changes anything to the actual PTP/MoveJ speed?

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#14
(12-23-2020, 05:24 AM)Jeremy Wrote: Hi Curt,

Sorry for the delay, I forgot to answer this one.
Looking at the second print screen of your Dec 11th post, lines 20 and 21, we see that the PTP speed is now 20%.
That should be good enough for it to work.
Does anything else override this command?
Can you manually change these values to see if it changes anything to the actual PTP/MoveJ speed?

Jeremy
Hi Jeremy,

Lines 20 and 21 with PTP speed at 20% has no effect on the speed of the 1st move to the Path Start. I have tested the program again today on the robot.
I am not sure what to check to answer your question "Does anything else override this command?" Where do I check to see if anything else overrides this command? 
We have changed these values previously which still had no effect on the speed of the 1st move to Path Start.

Curt
#15
Hi Curt, 

I think I got it. 


You need to change the "Fast move speed".
See here:

   

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)