Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Drill cycle issue
#1
Hi,

I have an issue with drill cycle. I have generated a G-code as APT and when I transfer it to "Machining project" in RoboDK i get an error message "Invaild cycle parameters". My question is: what parameters are needed to work properlty?


I sent a G-code and screenshot with error.

Best regards,
Piotr


Attached Files Thumbnail(s)
   

.apt   iMachining_2D_2.APT (Size: 2.68 MB / Downloads: 5)
#2
Hi Piotr,

You should add the DEPTH flag right before the depth value in your drill cycle command. You should also provide the speed units before the speed value. I assume you want 300 mm per minute. In this case we should see:
Code:
CYCLE / DRILL, DEPTH, 49.5, MMPM, 300, RTRCTO, 2

Instead of: CYCLE / DRILL, 49.5, 300, MMPM, 2. More information here.

In any case, we've improved RoboDK to support loading the format your provided (first value assumed as depth, last value assumed as retract value). However, speed units must be provided before the speed value.

On the other hand, you have some FEDRAT commands without units (you'll see a few warnings). If you add the units you should be able to import your file without issues.

One tip:
Since you are using multiple tools in the same file I recommend you to activate the option to automatically split the machining program in sub programs (one per tool). You should check the following 2 options:

In the Menu Tools-Options-CAM:
  • Automatically create one project per tool
  • Automatically create one project per program
   

Albert
  




Users browsing this thread:
1 Guest(s)