Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Error when generating a program "Syntax error in position data"

I started a test project for a Fanuc M-6i with a RJ3 controller.
When I try to generate the program I get an error (see image). 
What is the reason for this error and how can it be solved?
Best regards,

Fanuc controllers that have the ASCII Upload option accept LS files and can convert them to TP files automatically.

Did you try sending the LS file to the controller directly?
Did you use the Fanuc RJ3 post processor?
Hi Albert,
Thanks for your reply.
I'm generating the program but not sending it to the controller directly.
I assumed that using the RJ3 post processor would be the correct one but I also tried the RJ30 which gives the same result (error).
I also have a project with a R2000i robot. For this robot the generation of TP files works fine.
Before I switch over to the M-6i project I generate a new robot.ini file using setrobot.exe (not sure if this is required). This doesn't help either.

Any suggestions?

Users browsing this thread:
1 Guest(s)