Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Ethernet linked RoboDK -> Controller show different cartesian coordinates

I have an ethernet connection between RoboDK and my KRC4 controller.

When I select 'get robot joints' in the connection panel the cartesian rotation coordinates displayed are different from those displayed on the smartPAD. This is with or without a tool frame.

I think related is that I am getting singularity errors when I run a linear move on the robot through the RoboDK ethernet connection, even though when I run the same program as a simulation everything goes as planned.

Anyone with any idea what's happening or how to fix this?
Adding some information...

The coordinates according to RoboDK are shown in the first picture

Picture 2 shows the coordinates according to the robot. Position values are the same, orientation values are different

Next shows IpoMode selection as flange

When I change IpoMode to Ext. tool you can see in the final picture the orientation values match up but the position values do not

Problems with attachments so uploaded here:

Attached Files Thumbnail(s)
For some reason your robot panel shows a setup of 'Staubli/Mecademic' which defines the order of orientation.
By default they should be 'KUKA/Nachi/ABB' as you're using a KUKA robot.
You can use the drop down list to change it back.

Users browsing this thread:
1 Guest(s)