Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Failed to generate program with FANUC RJ3 post processor
#1
    Hello, 

I got an error as below photo when I tried to generate Fanuc RJ3 post processor.
It says, “Failed to generate program 1 using FANUC RJ3 post processor ” in Japanese.
I hope someone could solve this issue.
#2
Hi Hiroe,

That's strange.
I don't think that post V36 is included in the RDK release anymore.

Can you take a look at "C:/RoboDK/Posts and see if the v36 folder exists?
Otherwise, simply right-click the program -> "Select post-processor" and select the RJ3 from the list.
That should link to the latest version of the post.

Let me know if it still doesn't work.
Jeremy
#3
Dear Jeremy, 

Thank you for your quick reply.


However, there was no v36 folder at  "C:/RoboDK/Posts", and it does not work if I selecting RJ3 from the list.

I added a video explaining the error in program generation with RJ3 post processor.
I hope any clue would be found to solve this issue.

Best Regards,


Attached Files
.mp4   fanuc.mp4 (Size: 2.44 MB / Downloads: 6)
#4
Hi Hiroe, 

Very strange. 
Are you able to use any other post-processor? Or is this one the only problematic one?

If they are all problematic, go to "Tools"->"Options"->"Python" and make sure that the python37 is selected in the first text box. 

If the RJ3 is the only one you are having problems with, try replacing the one you have with this one in the attachment. 

Jeremy


Attached Files
.py   Fanuc_RJ3.py (Size: 10.86 KB / Downloads: 3)
#5
Dear Jeremy,

This issue was solved after installing the latest version and selecting python37.
Thank you for your kind guidance!

Hiroe Ota
  




Users browsing this thread:
1 Guest(s)