Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Fanuc LS to TP file


I am trying to use RoboDK generated paths to control our CRX-10iA/L. My issue is converting the LS files to TP ones.

I do have RoboGuide installed in my computer, but RoboDK is having trouble automatically converting them (image attached.) 

I looked into copying the files from C:\Program Files (x86)\FANUC\WinOLPC\bin into the C:\RoboDK\api\Fanuc folder, but I did not see a "Fanuc" folder. (Image of file directory attached). Also I looked into running setrobot.exe, but did not get the "Robot Neighborhood" window as described in another thread. I attached an image of the window I get when I run setrobot.exe.

Do you have any troubleshooting advice?



Attached Files Thumbnail(s)

Have you tried everything on this link:-

Let me know.
Hi Vineet,

I was able to fix the issue. I had WinOLPC installed directly on my computer from Fanuc as well as RoboGuide. When I uninstalled WinOLPC, RoboDK was able to locate the MakeTP file. I assume it interfered somehow.


Thanks for letting us know.

Users browsing this thread:
1 Guest(s)