Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Fanuc with a rail: go for 1 group or 2 groups?
#1
Hi,
A Fanuc robot mounted on a track (rail) has been used for milling large panels. The controller has been configured with only one group (group mask: 1,*,*,*,*). 
In RoboDK I've built this system. I want to use both the track and the robot, also for milling panels. The robot and the 'Mechanism' have been synchronized. The thing is that this RoboDK project generates files for a robot configuration with two groups (group mask: 1,1,*,*,*). This results in an error "Group mismatch" on the controller.

I guess there are two options to solve this problem:
1. Change the configuration of the robot controller in such a way it will accept program files with two groups,
2. Change the RoboDK project in such a way it generates programs with only one group.

My questions are:
a. Is it correct that these are my options?
b. How can I change the RoboDK project in such a way it will generate programs with only one group? 

Can someone advice me here? Would be great!

Emile
#2
Both options are correct.

You need to modify the post-processor.
If you own a professional version of RDK, go to "Help"->"Request Support" and ask for the specific post-processor you are using.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
Hi Jeremy,
Thanks for your reply.
I do use a professional version of RDK. I'm affright I don't understand exactly which information I should put in the "Request Support".
Right now I am using Post Processor Fanuc RJ3 (and I don't know how I could change it to get the desired result). I've asked them if they can provide a post-processor that will accomplish the solution described above.

Emile
#4
I just looked and you need the R30iA post with line 396 set to "True" to support the RJ3 controller.

You can then change line 546 from "If self.HAS_EXTAXES:" to "If False:" and it should give you the result you are expecting.

BUT, I don't think it's the right way to do that. You can try it out, it might work, but I think it should be properly set in the controller to accept the 2 groups.

Jeremyt<
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#5
Hi Jeremy,
Thanks, this trick does at least put the right Group mask in the file. Previously I manually modified the LS-files to make the group mask 1,*,*,*,* and in that way the robot controller can run the program. At first I thought that the problem I described in "https://robodk.com/forum/Thread-Position-unreachable" was related with the group mask but now I'm not so sure.

By the way, the Fanuc controller has two ways to be configured with an extra axis:
1. Add the extra axis as a second group (1,1,*,*,*),
2. Or add the extra axis as an 'extended' (7th) axis in group 1 (sub-group), mask 1,*,*,*,*
The robot at my customer is configured according to option 2. Is this option working with RoboDK? W.r.t. this configuration, would you please take a look at "https://robodk.com/forum/Thread-Position-unreachable" and check if you think it could be related... or that it is more likely that I've been messing up frames (although the simulation works perfectly fine)? Thanks in advance!
Emile
#6
Your second post is open on my browser, I just didn't have the time to look into it.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#7
Thanks! I can imagine you must be busy a lot ;o)
#8
The forum is just a small fraction of what I do, so yeah, days are flying.
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)