Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HELP: Error when loading program on Motoman NX100
#1
Hello, I'm hoping someone can help me out with this. Every time I export a Motoman program in PULSE coordinate it open on my NX100 fine, but the positions are all off. When I export it out in CARTESIAN it will not open on my robot and I keep getting an error that says "ERROR in JOB data record [13](J:CART_3 L:****)". 

Thank you!
Daryle


Attached Files
.jbi   CART_3.JBI (Size: 2.43 KB / Downloads: 11)
#2
Hi Daryle,

I believe this issue is related to the same issue you last posted on this forum. You need to make sure your tool 1 is properly defined on the robot controller.

You used a TCP with some coordinates in RoboDK, make sure they are the same (or close) on the robot controller. You'll see it when you generate the program:

'Tool 1 (TCP 1) should be close to:
'-133.4,-1.5,42.5,0.0,90.0,0.0

Also, I recommend you to make the first movement a joint move.

Albert
#3
Albert, Thank you for the response. I will go back through and validate the TCP today. There must just be something I am overlooking. Also, what's odd is that if I create a Target in RoboDK, look at its properties to get the coordinates, and then enter the coordinates into a position variable on my controller, it is spot on! Not sure if that helps narrow it down any. So everything seems ok until I generate a program.

Also, I apologize... I sent an email with this same info and said I had not received a response yet. Apparently I had, but it didn't update on my laptop until I logged out and then back in. Thank you again for the reply!
#4

.zip   Presentation1.zip (Size: 2.68 MB / Downloads: 8)
.zip   Presentation1.zip (Size: 2.68 MB / Downloads: 8) Albert, I have attached a powerpoint that will hopefully help. I verified that the TCP is spot on. I am not sure what else I am missing???? One things, and I'm not sure if this matters, when I generate a program it says "///TOOL 9" in the header, but I keep setting it to Tool Zero in the Options for Motoman Program. Does that have any effect on pulse positions?

Thank you!
Daryle
#5
Hi Daryle,

In your JBI program you'll see that you are linking to Tool ID 1. There is also a comment saying that you should modify Tool 1. In the image you shared you are modifying tool 0 (on the robot controller). I recommend you to keep tool 0 all at 0 mm and 0 deg and enter this information for Tool 1.

You can customize the tool ID you use in RoboDK by simply naming your tools accordingly. For example, if you want to use UTOOL 3 you should rename your tool in RoboDK to Tool 3.

Albert
  




Users browsing this thread:
1 Guest(s)