Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

How to hide ghost robots

In my workstation I manipulate and create targets a lot. Lots of ghosts show up and this is quite annoying.
I tried using the TimeGhostRobot Command with no success. I don't know if that can be caused by too many/too few RDK->Render() calls in my code.
If you have any clue please let me know
Did you set the TimeGhostRobot value to -1? This should disable the preview of ghost robots.
RDK.Command("TimeGhostRobot", -1)
If this doesn't help, can you provide us with more information and a way to reproduce this issue?
Hi, this doesn't seem to solve my issue... I'm quite busy at the moment but as soon as I can I'll provide an example. Thanks
Hi, I can't reproduce the issue in a python code. I tried to convert a C++ function I use in my plugin to python but the issue won't show up.
I attach the code of that function if it might help you figure out what's going wrong

RDK->Command("TimeGhostRobot", "-1");

//retrieve the starting target and its absolute pose
Item target = RDK->getItem("target_0_Extraction_0");
Mat targetPose = target->PoseAbs();

//translate the starting target
tXYZWPR xyzwpr;
xyzwpr[2] += 30;

//retrieve the active reference frame and create a new target
Item generalFrame = RDK->getItem("General");
Item newTarget = RDK->AddTarget("target_0_Extraction_1", generalFrame, itemRobot);

//set the previously calculated pose

I put my targets under generalFrame (which is the active reference frame) in my working station since I added a rail to the UR robot and had some difficulties in managing the targets if I put them only under the robotBase.
So my hierarchy looks something like

 | - Rail
 |   | - UR10e Base
 |   |   | - UR10e
 |   |   |   | - Gripper
 | - Targets
I understand the issue to not display ghost robots is now solved. Can you confirm?

If you have a rail and it is synchronized with your robot you should place all targets to the coordinate system of the rail or a static coordinate system (not moving with the rail). Please try to open a new thread if this is a new topic or issue.
no the problem is still there, but I can't reproduce it in a "fast" way in a python script that I can add to a station to show you. It still happens running the code from my plugin (and this is what I need to do).
This is the C++ plugin code that gives me the ghost problem.

I talked about the rail and stuff only to give you more context so you know what my setup looks like :)

Users browsing this thread:
1 Guest(s)