Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

INCLUDE_SUB_PROGRAMS not working as expected

I was trying to exclude the sub programs called in the main program when generating the robot program, and I tried adding the following code:

However nothing happened. RoboDK kept including the sub programs called in the main program.

Has anyone encountered such problem before? Is there any possible solution to this matter? I'm using python 3.7. Thanks ahead!
You can easily change this setting here:
  1. Select Tools-Options-Program
  2. Uncheck Include available subprograms
Not all post processors can be customized for this purpose. It may be better to set it up with the instructions above.
Worked like a charm.
Thanks Albert!

Users browsing this thread:
1 Guest(s)