Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Incorrect robot workspace shown for active TCP

Hey, I'm having issues with showing the correct workspace for my active TCP. Please see attached image for further details. 

I'm on V5.2.4.

Attached Files Thumbnail(s)
Thank you for letting us know about this issue. We just updated RoboDK to improve displaying the workspace for UR robots when you have a custom tool (only the Windows 64 bit version has been updated for now).

Note that the workspace displayed by RoboDK is an estimate. The real workspace highly depends on the orientation of the tool. I recommend you to use the Reachability app to test the reachability of a point given different orientations:
  1. Select Tools->Plug-Ins
  2. Make sure the App Loader plugin is loaded
  3. Select Tools->Apps List
  4. Make sure the Reachability app is loaded
I moved this thread to the bugs section.
Thanks for your reply, Albert.

Wanted to ask if there is any documentation available for the Reachability app, not too sure how it works at the moment.

I can also confirm that I am still facing the same issue.

I have read the changelog and noticed the following changes on the 2nd of August:

New in RoboDK v5.2.4 (2021-08-02)

 Improved Staubli post processor
 Improved UR workspace when using tools
 Fixed Kinova driver (there was a monitoring bug)
 Added option to hide ghost robot when teaching targets on a surface
 Added probing support for KUKA robots

I am on version V5.2.4.20742 and when I click on the "check for updates" button it says I am up-to-date. 

If there's anything else you'd like to me to test, let me know!
As the major release number didn't change (5.2.4) RDK still thinks it's up-to-date.
Go on our website and download a fresh install and run it (no need to uninstall the one you already have).

Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


Users browsing this thread:
1 Guest(s)