Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues with starting RoboDK, will not load.
#1
RoboDK GUI opens, then shuts down. I have updated my laptop Windows and Graphics Drivers, with a Firmware update. Uninstalled RoboDK, reinstalled it twice. I tried opening RoboDK in Safe-Start.bat and it throws an Error.
   


#2
We just pushed a new update of RoboDK which includes the RoboDK-GL2.exe version. Let us know if you still have issues starting with RoboDK-Safe-Start.bat.

In any case, the default version of RoboDK should work unless you have an old computer or the wrong graphics card drivers installed. If you can provide the debug log we can help you better.
#3
Here is the new Txt File. Since the push the RoboDK-GL2 application is in the Bin folder.

.txt   RoboDK.debug.txt (Size: 1.14 KB / Downloads: 7)
#4
I confirm the issue is related to graphics card drivers.

Are you able to run RoboDK by double clicking the RoboDK-Safe-Start.bat file?

Can you provide more information about your computer? (Hardware, Windows version, etc)
#5
I noticed looking at the DeBug file, the Lang folder does not have the qt_en.qm file in it.

   
   

   


Attached Files Thumbnail(s)
   
#6
Can not run RoboDK-Safe-Start.bat, goes to load then crashes.
#7
This issue is very strange. I believe it is related to the lack of support for OpenGL wtih your graphics card. I believe it is software-related (wrong drivers). You have a very new Intel i7 CPU so it should not be hardware-related.

Did you install all recommended drivers by Windows?
Have you been able to use any other CAD/CAM software that require using OpenGL?
#8
I had our IT guys, upload all the latest drivers for the NVidia Graphics card and upgrade the firmware. I run Autodesk Fusion 360 with out any issues. What settings should the NVidia 1200 GPU graphics card be set to, to run this software?
#9
Try forcing OpenGL through your Nvidia Graphics card:
  1. Open the NVIDIA Control Panel (right click on your Desktop and select NVIDIA Control Panel).
  2. Select Manage 3D settings from the left tree.
  3. Select the Program Settings tab.
  4. Choose RoboDK as the program to customize.
    Select Add if you don't see RoboDK, then, sort by Recently used and select RoboDK. Then, select Add Selected Program.
  5. Change the following setting:
    OpenGL rendering GPU: Select your graphics Card (NVIDIA T1200, or mine is NVIDIA GeForce RTX3080)
I attached an image of what it looks like on my computer. Note that default settings or specifying the use of graphics card both work for me.
   

Another topic: Do you use multiple screens? This issue could be related to selecting the correct screen. If so, can you try starting RoboDK with only 1 screen?
#10
I just tried that and it didn't make any difference. I'll get back to the IT guys tomorrow and see if I have the correct permissions. Thank you for all your help so far.
  




Users browsing this thread:
1 Guest(s)