Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Kuka KRC4 DAT Post Processor - Base problem
#1
Hello,
I created a simple robot progam. The points are teached and placed in a reference frame.
When I compile the programm with the default Kuka post processor everything works fine. After switching to the DAT post processor, my linear movements doesnt fit. It seems like the robot doesnt use the reference frame / base.

Is there any option to fix this? I would like to use the DAT post processor to be able to use the kuka touch up funtion.

Also I have a bug that my filename ist always 2 times the same.

Attached you will find the project and the compiled files.


Thank you!


Attached Files
.zip   robotfiles.zip (Size: 2.78 KB / Downloads: 8)
.rdk   Kuka_Problem.rdk (Size: 1.17 MB / Downloads: 10)
#2
You should update RoboDK to the latest version to fix the problem you see with the double file name. This was a known bug we fixed.

Regarding base and tool ID you should remove the comment on the line where you set the base:
Code:
BASE_DATA[5] = {FRAME: X 365.454,Y -483.317,Z 669.023,A 0.445,B -45.223,C 89.945}
Same thing for the tool.

This can be easily configured in the post processor. More information here:
https://robodk.com/doc/en/Post-Processor...SamplePost

You can contact us by email if you don't have the source code of the KUKA KRC4 DAT post processor.
#3
Hello Albert,

Ok I think there is a problem with the tool data.

The tool is definded as the following:

Code:
; ---- Setting tool (TCP) ----
$TOOL = {FRAME: X 100.000,Y 0.000,Z 307.300,A 0.000,B 5.000,C 0.000}
; --------------------------

And the linear movement refers to TOOL_NO 1:


Code:
DECL E6POS XP2={X 301.325,Y 325.389,Z -247.213,A -36.052,B 28.427,C -55.569}
DECL FDAT FP2={TOOL_NO 1,BASE_NO 5,IPO_FRAME #BASE,POINT2[] " ",TQ_STATE FALSE}
DECL LDAT LCPDAT2={VEL 1.00000,ACC 100.000,APO_DIST 1.000,APO_FAC 50.0000,AXIS_VEL 100.000,AXIS_ACC 100.000,ORI_TYP #VAR,CIRC_TYP #BASE,JERK_FAC 50.0000,GEAR_JERK 50.0000,EXAX_IGN 0}

Is it possible to choose which tooldata robodk should be used?
Or do I have to edit the postprocessor?

I also updatet to the newest version of robodk :)
#4
Actually you should be able to configure the post processor to automatically use indexes for the TOOL and the BASE when available. Make sure the index number is available in the name of the tool and reference frame.

To apply this change by default simply edit the following variables of the KUKA KRC4 DAT:
Code:
   # Use the Frame index instead of the pose when the index is provided
   # Example: Set to True and rename your reference to "Frame 2" to use BASE_DATA[2])
   BASE_INDEX = True
   
   # Use the Tool index instead of the pose when the index is provided
   # Example: Set to True and rename your tool to "Tool 3" to use TOOL_DATA[3])
   TOOL_INDEX = True
The post processor available here: C:/RoboDK/Posts/.

If you want this change to be permanent it is better if you create a copy of this file so that reinstalling RoboDK does not override your changes.
  




Users browsing this thread:
1 Guest(s)