Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
License Dongle not working with Ubuntu 20.04
#1
Hi, I have installed Ubuntu 20.04 on a machine and plugged in the dongle but RoboDK is not detecting the dongle. When I run lsusb on the dongle's device ID
Code:
lsusb -s 21 -v

it says
Code:
Bus 001 Device 021: ID 1bc0:8101
Couldn't open device, some information will be missing
Device Descriptor:
 bLength                18
 bDescriptorType         1
 bcdUSB               2.00
 bDeviceClass            0
 bDeviceSubClass         0
 bDeviceProtocol         0
 bMaxPacketSize0        64
 idVendor           0x1bc0
 idProduct          0x8101
 bcdDevice            1.00
 iManufacturer           0
 iProduct                0
 iSerial                 3
 bNumConfigurations      1
 Configuration Descriptor:
   bLength                 9
   bDescriptorType         2
   wTotalLength       0x0022
   bNumInterfaces          1
   bConfigurationValue     1
   iConfiguration          0
   bmAttributes         0x80
     (Bus Powered)
   MaxPower              100mA
   Interface Descriptor:
     bLength                 9
     bDescriptorType         4
     bInterfaceNumber        0
     bAlternateSetting       0
     bNumEndpoints           1
     bInterfaceClass         3 Human Interface Device
     bInterfaceSubClass      0
     bInterfaceProtocol      0
     iInterface              0
       HID Device Descriptor:
         bLength                 9
         bDescriptorType        33
         bcdHID               1.11
         bCountryCode            0 Not supported
         bNumDescriptors         1
         bDescriptorType        34 Report
         wDescriptorLength      52
        Report Descriptors:
          ** UNAVAILABLE **
     Endpoint Descriptor:
       bLength                 7
       bDescriptorType         5
       bEndpointAddress     0x81  EP 1 IN
       bmAttributes            3
         Transfer Type            Interrupt
         Synch Type               None
         Usage Type               Data
       wMaxPacketSize     0x0008  1x 8 bytes
       bInterval              10

Any thoughts on how to resolve this? Other USB devices connected to this machine are working, and I know the dongle works in my Windows machine.
#2
You should start RoboDK with root privileges so RoboDK has access to the USB device.

Example:

Code:
sudo ./RoboDK-Start.sh
#3
Gotcha! Thanks.

I also just came across the usb-dongle-setup.sh in the RoboDK folder which provides several options to address this:


Code:
If you have a USB dongle license you may need to follow one of the following procedures to make the USB dongle work with RoboDK:

1. Make the device "hiddev0"(the dongle device) readable and writable
sudo chmod +666 /dev/usb/hiddev0

2. The first option, run the demo with root permission:
sudo ./RoboDK-Start.sh

3. Add one line code to this configuration file:
sudo nano /etc/udev/rules.d/70-persistent-usb.rules
KERNEL=="hiddev[0-9]*",MODE="0666"

4. Alternatively, modify the following file:
/etc/udev/rules.d/80-persistent-usb.rules
SYSFS{idProduct}=="8101",SYSFS{idVendor}=="1bc0",MODE="666",OWNER=“username",GROUP="groupname"
  




Users browsing this thread:
1 Guest(s)