Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Linear move on Robot rotates Z 180 Video Link in description

Hi there,
Robodk is behaving a little unusual when in practice in the linear move joints and i have been trying to solve it for days myself and not getting anywhere,
The example I am using follows the Painting exercise which was on your Youtube channel tutorial.
My robot is efort with Kairo post-processor.
I have created the robot and the joins work perfectly. I am happy to send you the robot file for you to add to your library if you like.
The issue i am having is;
As soon as the linear move is started using the Teach target on the surface, the Joint 6 Rotates negative 180 degrees in the Z (relative to TCP).
So far I have made sure that the Euler Angle is correct for the robot. It is ZYZ so I have set it to "Adept/Comau". I have tried to reorient Frame 2 (surface) by rotating it positive by 180.
I have redone the exercise a few times and it is still producing the same result. In the video of the actual robot, you can see the tab is on the "Right" and when it starts the linear move it rotates to the left.
Below is a private video i have uploaded to show the issue.

YouTube Video Here

Many thanks in advance,
Can you share the station or send it to me privately if you prefer?
Can you share your station so that we can take a look?
That's kind of weird.

Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel

Thank you Oliver and Jeremy.

Please see the attachment for the station. The post-processor I am using is Kairo since it is a Keba Controller. I have also included the eFort ER7L-C10.robot file and am very happy for you to upload it to your library. I have another robot I will create and also upload.

Thanks in advance

Attached Files
.robot   efort-ER7L-C10-New.robot (Size: 2.4 MB / Downloads: 264)
.rdk   PaintingExampleKairo.rdk (Size: 2.4 MB / Downloads: 197)
Can you confirm that the X axis of the flange is pointing down and not up on your robot? 

Try jogging the robot on the x axis in tool mode with the tool all set to 0,0,0,0,0,0 and let me know if the direction is correct. 

Here is a picture of a HUIBO robot using the Kairo post-processor with a KEBA controller next to your model for comparison.

Also, the base ref of the robot you made was too high. This was causing the rotation of the flange not being centered correctly. (see capture 1 and 2)

I joined the robot with the modifications, let me know if using this version fix the issue.



Attached Files
.robot   efort-ER7L-C10.robot (Size: 2.38 MB / Downloads: 270)
Hi Olivier,

You are genuinely amazing! Thank you so much for your 2 fixes and i am so sorry for my mistakes in the robot creation. I am rather new to this awesome software and tried to follow Jeremy's brilliant tutorials but clearly, I didn't do it correctly.

I made a quick linear and rotation move set up with your robot and it works perfectly.

Many thanks again,

Users browsing this thread:
1 Guest(s)