Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Mecademic driver on MacOS not working

#1
I'm having an issue connecting to a Meca500 R3 arm via MacOS. When I try to connect, I get an error with apimecademicpy.py. Here's the error:

Code:
python /Users/brandon/RoboDK/RoboDK.app/Contents/MacOS/apimecademicpy.py      
Traceback (most recent call last):
 File "/Users/brandon/RoboDK/RoboDK.app/Contents/MacOS/apimecademicpy.py", line 26, in <module>
   exec("from v" + version_str + ".apimecademicpy import *")
 File "<string>", line 1, in <module>
 File "C:\RoboDK\api\robot\apimecademicpy.py", line 98, in <module>
 File "C:\RoboDK\api\robot\apimecademicpy.py", line 175, in MecaRobot
AttributeError: module 'mecademicpy.robot' has no attribute '_Message'
Note that despite the windows paths listed above, I assure you this is on MacOS. Specifically Ventura, robodk 5.5.3.-23011. I see the same error in the GUI log and running python apimecademicpy.py in terminal. Thanks for the help

-Brandon
#2
You can try updating to the latest version of the mecademicpy library by unzipping the attached folder here:
/Users/brandon/RoboDK/RoboDK.app/Contents/Python/apimecademicpy/

Then, force stop the driver by double clicking on Disconnect and try connecting again.

I took this from the latest official version of mecademicpy:
https://github.com/Mecademic/mecademicpy


Attached Files
.zip   mecademicpy.zip (Size: 78.07 KB / Downloads: 156)
#3
(04-07-2023, 08:19 AM)Albert Wrote: You can try updating to the latest version of the mecademicpy library by unzipping the attached folder here:
/Users/brandon/RoboDK/RoboDK.app/Contents/Python/apimecademicpy/

Then, force stop the driver by double clicking on Disconnect and try connecting again.

I took this from the latest official version of mecademicpy:
https://github.com/Mecademic/mecademicpy

Hi Albert,

I tried as directed and no change. I'm not sure why the last part of the path you suggested was apimecademicpy and not mecademicpy. I assume a typo because the former doesn't affect the module __path__ when I directly import mecademicpy.robot, but the latter does. I confirmed with mecademic.robot.__version__ that I'm getting 1.3.0, which is the latest according to their GitHub. Looking through mecademic.robot code, I don't see any reference to _Message. 

Given the error message AttributeError: module 'mecademicpy.robot' has no attribute '_Message', it seems like this is apimecademicpy calling something incorrectly, specifically mecademicpy.robot._Message. Does the compiled pyc call mecademicpy.robot._Message?
#4
Also, I'll be away from work for the next week. So please don't let a lapse in my responses stop with any new help/suggestions. Thanks!
#5
We updated RoboDK to the latest version for Mac, including our latest version of the apimecademicpy driver (which fixes the specific issue related to _Message).

You can take the latest version here:
https://robodk.com/downloads/Install-RoboDK.dmg

Let us know if you still have issues.
#6
Hi Albert, thanks for the follow-up! Things seem to be working as expected now.

-Brandon
  




Users browsing this thread:
1 Guest(s)