Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Motoman Motocom DLL license problem

I use RoboDK on a Yaskawa Motoman DX100 controller with MOTOCOM hardware key and it work whit sample program supply from Yaskawa. But if i try to use RoboDK, I see this message on the log:
Connecting through Packet Server to IP:
License problems. MotoCom license is not detected.
Not connected
CONNECT 6;2285.714286;2335.897436;2055.555556;1841.269841;1673.202614;977.462289
Connecting through Packet Server to IP:
License problems. MotoCom license is not detected.
Not connected
Is this a MotoCom license problem?

I have closed all program using the Motocom Hardware key...

Some one can help me?
The following message means that the Motocom license key from Motoman is not detected (HASP key):
"License problems. MotoCom license is not detected."

Motocom  is a software option sold by Yaskawa/Motoman, not RoboDK. This allows you to use the online programming features of RoboDK. This is useful for setup purposes and being able to move the robot directly from your computer. This option is not required for standard offline programming.

Without this option you should still be able to generate JBI robot program files. Load them on the robot controller and run the program. This does not require the robot to be connected to the computer.

Let us know if you need more help.
Thanks Albert, I have checked the Motoman HASP Key with a demonstration key from Yaskawa and it works. I'm calling Yaskawa team to check.
I have solved the problem, there are 3 type of Motoman Motocom licenses: Europe, USA and Japan. The DLL included with RoboDK use Halladdin protection with 3 different vendor code.

I have replaced the Motoman Motocom DLL whith my European DLL and all works well.
I am using a UP6 robot with an XRC controller with a serial connection, and have the same problem.
We have MotoCom32, and a hardware license key (connected to DB25). I am able to communicate with the robot through the basic motocom applications, but RoboDK gives me the license error.

I have tried replacing the MotoCom32.dll file in \RoboDK\api\Robot\ with the file in my MotoCom installation, but it gives me the error: "The procedure entry point _BscGetPulsePos@8 could not be located in the dynamic link library MOTOCOM32.dll".

I restored the version of MotoCom32.dll, and replaced Motolk.dll and Motolkr.dll with my MotoCom version's. This seems to have solved the license issue, but it gives me a "Data transmission failure (error code = -1); Unknown error code; Failed to get pulses data" error.

What did you replace, and were you able to connect to the robot through RoboDK?
@yoavgolan1 I have a few old Motoman bots on XRC controllers as well.  I'm not quite to the point where I can hook them up (still packed on the crates) but I would also like to see how we can use robodk with them.  Let me know what you find!  Very interested in hearing what comes into play for this.
Hi @Jacob,
Hi @yoavgolan1,

We look forward to developing a driver that works for Motoman Serial communication (to support XRC controllers). It should not be complicated and we already have a draft. However, it would be great to setup a call so we can debug remotely before we launch a release. 

@Phillip would be the main point of contact. It would be great if you can send us an email at to go more into details and schedule a conference call.


Sounds great @Albert. Thanks for the help!

Users browsing this thread:
1 Guest(s)