Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New arm error Panda
#1
I have managed to introduce the 3d model and create the robot model with the limitations of the axes within roboDk, I have created the robot file, but I have a problem that I cannot solve, since when entering a target it produces an offset with respect to the flange. I leave an image to show the error that I have, can someone tell me how to eliminate that offset?

Attached file


Attached Files Thumbnail(s)
   
#2
Hi EndiCamp,

Can you send us your RoboDK station?

Jeremy
#3
(10-13-2020, 02:05 PM)Jeremy Wrote: Hi EndiCamp,

Can you send us your RoboDK station?

Jeremy

Hi Jeremy, the model is not finished, I have to take some data from the real robot, I think that some angles are not inserted correctly, and some starting position is not correct, anyway I send you the station so you can check it. I'm new to robodk and maybe I did something wrong


Attached Files
.robot   Franka Emika Panda.robot (Size: 1.82 MB / Downloads: 7)
#4
Hi EndiCamp,

For 7-axis robot you need to activate the iterative kinematic.
"Robot panel"->"Parameters"->"Inverse Kinematic"->"Options"->"Use iterative kinematics".
You need to note that an iterative kinematic won't give you perfect results, if you want to have a perfect kinematic, you can create this robot as a 6-axis robot with J3 locked at 0 deg.

Jeremy
  




Users browsing this thread:
1 Guest(s)