Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Problem with colors since V5.5.4

#1
Hi,

I have a trouble with the objects color since version 5.5.4 of RDK.
We often export .stp files from Inventor and use it in RDK. When importing, the "order" of the colors is not always good (paint color is inside steel part instead of outside) : (image3.jpg)
   

To view the colors, we get use to change the transparency of this color from 255 to 250. That way we can see througt this color and still keep the visibility of objects with this color : (image2.jpg)
   


The problem is that since version 5.5.4 of RDK, it doesn't work anymore. We keep having the wrong color order as in first image. I tried to put transparancy to 0 : it works but some objects desapears.

I noticed that even the colors values are not the same when importing the same .stp object  : (image1.jpg)
   


Is there any fix to make it work as before ?

I added the step file if you want to try.
.stp   Chariot robot.stp (Size: 699.62 KB / Downloads: 147)

Thanks in advance,
regards.

Nicolas
#2
You can split an object into surfaces and remove duplicate surfaces. Then, you can merge these surfaces back into an object.

We can help you better with your 3D model but you forgot to attach the STEP file.
#3
Thanks Albert, I updated my message to add images and step files.
#4
I tried to remove duplicates surfaces but there are so many surfaces. Is there an automatic way to do it ? 
Or an other solution ?

Thanks
#5
Hi, for information colors appears when using Snapshot app :

View from RDK 5.6 :

   

File generated by snapshot app : 

   
#6
A better way to change this is by changing the order of the geometries.

As you can see, when you split the part the first geometry ( chariot robot - 0 ) has the complete part but no colors.
   

If you move this geometry to the bottom, the render order will change and the other geometries will be shown on top:
(notice 0 is now the last one)


You can merge the geometries and keep it as an object. (see attached)
   


Attached Files
.sld   Chariot-robot.sld (Size: 310.04 KB / Downloads: 142)
#7
Hi RoboDK team. I found a way to solve the problem :

The colors works only in this configuration :
- RoboDK v5.6.7.23830
- Display tree preference : Side Windows (opaque).

With version 5.6.8 it doesn't work anymore. If you change display tree preference to (transparent) it doesn't work.

If it can help you find the problem or help others.

Regards
#8
Did you tried following the advice provided by Alex in his previous post on this thread?

Colors should work with the latest version of RoboDK.
  




Users browsing this thread:
1 Guest(s)