Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems while changing fanuc M710 geometry
#1
Hello, I have the following tool configuration (as shown in the picture). The distance between the real axis and the robot axis is 200 mm. The reduction ratio is 1:1.
[Image: 7d05fd15b18e.jpg]

In order for the geometry to be correct, I changed the distance (a) of the 6th axis in the robot settings. On the 3D model, this change was displayed correctly, but when the simulation is started, the robot refuses to work correctly (see the video). Please tell me what I did wrong and how can I solve this problem?
[Image: 10ce04b362c2.jpg]

#2
To account for this modification you should not change the a6 value in the DH table but add a translation in along the X axis of your Tool Frame.
#3
Albert, thank you. So, as you said, I tried to do, if it doesn't need to follow the tool along the path, then it will work. In other case, this does not work correctly because the tool is fixed to the 5th axis and is driven by the 6th axis.
May be I need to rebuild robot source?
#4
Can you send the RDK project file?
You probably need to select Update to recalculate your path.
#5
(02-27-2020, 01:55 PM)Albert Wrote: Can you send the RDK project file?
You probably need to select Update to recalculate your path.

I can send the file, it's not difficult. Naturally, I clicked on the (update) button. The question is different. Is it possible to somehow add the A6 coordinate when creating the robot?

[Image: 9e5322cbc261.jpg]
  




Users browsing this thread:
1 Guest(s)