Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with setting a Rounding Instruction
#1
Hello everyone,


While working on my first robot program, I tried to incorporate a Rounding Instruction over a certain point.

However, when this program is started, the robot accelerates to maximum speed and ignores the set radius of 50 mm. The components that are moved with pick and place are partially placed one inside the other. Without the "Set Rounding Instruction" program step, however, all components are placed in their correct position via the programmed path.

What could be the reason?
#2
Hi Sascha,

What robot brand are you using?
Can you join the .rdk station?

Have a great day.
Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
(11-25-2020, 07:08 PM)Jeremy Wrote: Hi Sascha,

What robot brand are you using?
Can you join the .rdk station?

Have a great day.
Jeremy

Hi Jeremy,

I using an UR10. I think Im not allowed to share it.

I have included a picture of the program sequence in the Attachment.

As soon as the "Glatt (50)" step starts, the robot becomes incredibly fast and the moved component ends up several centimeters off when it is put down.

Cheers
Sascha


Attached Files Thumbnail(s)
   
#4
Ok, I think I see the issue. 

First, make sure your station is not in "fast simulation" mode:

   

If you see the "fast-forward" sign as in the picture, you are good, if you only see a play button, press it once. 

You can also make sure your simulation ratio is not too high. 
"Tools"->"Options"->"Motion"->"Simulation time ratio"
Start with 1 and see if it fixes the issue. 



But on the other hand, I want to mention that what you are doing is not consider as "good practice" and could lead to issues with the real robot. 
Blending is good for fluid motions, path transition, and that kind of stuff. 
But you should always use a "fine" motion before picking an object. 
So before picking an object, you should always have a "rounding = -1". 
This way, the robot will stop at the specific position, pick the object, then go to the next position. 
Otherwise, good chances are the gripper output will be triggered before you reach the actual position. 



Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#5
(11-26-2020, 05:51 PM)Jeremy Wrote: Ok, I think I see the issue. 

First, make sure your station is not in "fast simulation" mode:



If you see the "fast-forward" sign as in the picture, you are good, if you only see a play button, press it once. 

You can also make sure your simulation ratio is not too high. 
"Tools"->"Options"->"Motion"->"Simulation time ratio"
Start with 1 and see if it fixes the issue. 



But on the other hand, I want to mention that what you are doing is not consider as "good practice" and could lead to issues with the real robot. 
Blending is good for fluid motions, path transition, and that kind of stuff. 
But you should always use a "fine" motion before picking an object. 
So before picking an object, you should always have a "rounding = -1". 
This way, the robot will stop at the specific position, pick the object, then go to the next position. 
Otherwise, good chances are the gripper output will be triggered before you reach the actual position. 



Jeremy

So...

I have now followed all the instructions. The error persists.

I have now set "-1" at the last step before picking. The robot now moves very slowly until it reaches the step "Glatt (50)". Then it becomes super fast (almost jumping) until it reaches the Rounding with "-1". From here he proceeds again with a Simulation time ratio of 1.
#6
Hi Sascha,

It's pretty hard for me to help you if I can't access your station.

Maybe you could recreate the same issue without any confidential information.

One other thing I could see would be the robot speed itself.
If you double-click the robot, the Robot panel will appear (most likely on your right) -> Top right corner "parameters".

You will then see the default robot speeds (linear and joint) and accelerations.
You can change those there.
You can also add a "setspeed" to your program (I would recommend this option).
Right-click the program->"Add instruction"->"Set speed".

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)