Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Program error generating Universal Robots URP programs

#1
I am trying to output a simple test program and have the Universal Robots URP post processor selected. When I create the program all I get is a URP file with scripts inside of it. No way to edit this inside polyscope. I've tried deleteting and reinstalling RoboDK and it did nothing.


Attached Files Thumbnail(s)
   

.rdk   URP Test.rdk (Size: 4.76 MB / Downloads: 168)
#2
You should use the post processor called Universal Robots URP.

Follow these steps in RoboDK to change the post processor:
  1. Right click your robot
  2. Select Select Post Processor
  3. Select Universal Robots URP
  4. Generate your program again.
You should obtain a URP file in the same folder where you see the script.
#3
Yes I have tried both Universal Robots and Universal Robots URP.

attached is the URP program.


Attached Files
.urp   URPTest.urp (Size: 694 bytes / Downloads: 131)
#4
I noticed that only the set tool instruction and move joints to a joint target are output as scripts.

I believe these instructions were not available in the UR Polyscope interface in the past and this is why we generate it as a script line by default, so we can keep it backwards compatible. However, you can alter output by changing some flags in your post processor. For example, you can set the variable SKIP_MOVEJ to True to generate a proper Polyscope instruction instead of script code for a joint movement.

You can find more information here:
https://robodk.com/post/Universal-Robots-URP
#5
I set "Skip_MOVEJ" to true and now i dont get anything in polyscope.


Attached Files Thumbnail(s)
   
#6
You are right, the Move Joint movement is simply ignored. At this moment there is no other workaround.

If you have a Professional license you can contact us through Help-Request support from RoboDK Software and we can try to improve the post processor further.
  




Users browsing this thread:
1 Guest(s)