Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
QTcpSocket issues on Ubuntu 20.04 while PRM calculation
#1
Hello,

I have some issues with Example-09.c-PRM Automated Collision Avoidance - Comau.rdk on Ubuntu 20.04. My idea is to build the map and after to find a path between two positions. So I modified the script a bit. I run attached file from GUI, it creates collisioin-free map but never goes further. 

/var/log/syslogs ends with:

Code:
Aug 16 09:25:28 ubuntu-20.04 gnome-shell[1709]: Adding new docked window:  "Robot Comau Smart5 NJ 165-3.4 SH joint list: 25"
Aug 16 09:25:28 ubuntu-20.04 gnome-shell[1709]: Statusbar:  "Pasted joint sequence from clipboard to Comau Smart5 NJ 165-3.4 SH"
Aug 16 09:25:28 ubuntu-20.04 gnome-shell[1709]: Done calculating PRM
Aug 16 09:25:28 ubuntu-20.04 gnome-shell[1709]: Done with API Command:  "PluginCommand"
Aug 16 09:25:28 ubuntu-20.04 gnome-shell[1709]: Detected closed socket while commands were being processed QTcpSocket(0x55d2d1587960)
Thanks in advance,
Yury


Attached Files
.py   PRM Automation Examples.py (Size: 3.74 KB / Downloads: 48)
#2
Are you using a recent version of RoboDK? You probably need to increase the connection timeout.

You can set the connection timeout in seconds using _setTimeout:
Code:
RDK._setTimeout(60)
#3
(08-17-2022, 05:13 AM)Albert Wrote: Are you using a recent version of RoboDK? You probably need to increase the connection timeout.

You can set the connection timeout in seconds using _setTimeout:

Code:
RDK._setTimeout(60)

I use 5.4.3.22350 Release.

The same result even if timeout is 600.
#4
(08-17-2022, 05:13 AM)Albert Wrote: Are you using a recent version of RoboDK? You probably need to increase the connection timeout.

You can set the connection timeout in seconds using _setTimeout:
Code:
RDK._setTimeout(60)

Looks like it's server-side (robodk engine) issue. Is it possible to increase timeout there?
#5
We just updated RoboDK, including RoboDK for Ubuntu. I was unable to reproduce this issue. Could you try updating RoboDK to the latest version?

Also, make sure you have the Collision-Free motion planner plugin enabled (in Tools-Plug Ins).
#6
(08-29-2022, 10:06 AM)Albert Wrote: We just updated RoboDK, including RoboDK for Ubuntu. I was unable to reproduce this issue. Could you try updating RoboDK to the latest version?

Also, make sure you have the Collision-Free motion planner plugin enabled (in Tools-Plug Ins).

So you can run my script without any issues and it builds the path?

I installed current version. The same problem: it generates collision-free map, but it never generates the path. And I can't see any messages in the /var/log/syslog.

Btw where can I find python's print(...) output?
#7
I confirm I was able to run your script without issues. What Python version are you using? You can find it in Tools-Options-Python.

You can open your script with any Python editor and run it. Make sure to install the RoboDK API for Python manually if you run Python scripts from outside of the RoboDK environment:
https://pypi.org/project/robodk/
  




Users browsing this thread:
1 Guest(s)