Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Real-Time Connection Issues with KUKA KR10 Robot

#1
   
Hello,
 
I am a university student in my final semester, and I am currently facing a challenge in a project related to industrial robotics. I am trying to establish an online connection with a KUKA brand industrial robot arm, model KR10 with a KRC4 controller, using the RoboDK software for my final project. Despite following the instructions in the English documentation, I am unable to successfully establish the connection.
 
Here are the steps I have taken:
 
I assigned the IP address to the robot arm's controller.
I enabled port 7001, considering that the controller uses Windows 10 IoT.
I connected the robot's controller to my laptop (also with Windows 10) via a crossover Ethernet cable.
When I try to connect to the robot and perform a "ping", I receive a success message in the popup window. However, when I click on "connect", a message in red saying "Connecting" appears, but the connection is not established.
 
Additionally, I have installed C3bridge on the controller and run it every time the robot is turned on. I have also disabled the firewall and antivirus to prevent potential interferences.
 
I would appreciate guidance on whether there is any specific configuration or additional steps I should follow to be able to control the robot's movement in real-time through RoboDK.
 
Any help or suggestion would be greatly appreciated, as it is crucial for the success of my graduation project.
 
Thank you in advance.
#2
Most likely the problem lies in the fact that the C3 Bridge Interface Server process itself is trying to open port 7000 (instead of the 7001 you need) in the control system.
I forgot to mention this aspect in the documentation and this case will be an excuse to supplement it.

You need to open the Registry Editor (on the robot control system), navigate to "HKEY_CURRENT_USER\SOFTWARE\C3 Bridge Interface" and change the value of "NetworkTcpPort" key (selected on the attached screenshot).

Do not forget to shut down the C3 Bridge Server application before editing the registry.
After editing the registry and then running C3 Bridge Server, restore it from the notification area (system tray) and check if the log says something like this:
Quote:[01/10/24 15:29:50] C3 Bridge Interface Server is running and available at 'COMPUTER-NAME:7001'.


Attached Files Thumbnail(s)
   
#3
"I have followed your recommendation to switch to port 7001 (and, but I have encountered some problems. When I try to connect using the IP 192.168.0.1, which corresponds to the robot's controller, I receive certain error messages. However, if I use the IP 192.168.0.2 (my laptop's IP), the message changes, indicating that a connection has been established, but it then shifts to a 'working' state, followed by a disconnection due to a 'socket error', and it then attempts to reconnect. Additionally, I connected the Ethernet cable to port X66, but I still cannot establish a stable connection with the KUKA robot. I have tried to follow the documentation, but I am having difficulties connecting to the KUKA robot. I know your time is valuable, and I would greatly appreciate it if you could please assist me with a video conference, to help set up the online connection between RoboDK and the KUKA robot arm, as I cannot graduate from university without it."


Attached Files Thumbnail(s)
       
Image(s)
   
#4
As far as I remember, you cannot use such IP addresses on KUKA controllers.
The network number 192.168.0.XXX is reserved for communication between Windows and VxWorks on the robot control system.
Use smartHMI to configure the network correctly.
For example, set the address 172.1.1.1 for the management system. Remember to change the network configuration on your computer as well.
#5
I have tried to implement the solution you suggested, which involved changing my computer's IP addresses to those of the Kuka robot, but unfortunately, I was not successful. I conducted a Ping test using the "cmd" command, which showed a 50% data loss. Also, I performed a ping through ROBODK, resulting in a SUCCESSFUL ping. However, when trying to connect, the connection does not establish, as can be seen in the attached image. In addition, I clicked on the "EXPLORE" option next to the robot's port, which led me to the page "https://filezilla-project.org/download.php?type=client". I downloaded and installed the file from the page and, when clicking on "Explore" again, the installed program opens with a message that it is trying to connect, but without success.

I have attached images showing the IP addresses I configured on both my laptop and the SmartPad, the error messages mentioned above, and the model of the robot I am using. I greatly appreciate your help and hope you can assist me again to solve this problem and achieve a real-time connection with the Kuka robot through RoboDK.


Attached Files Thumbnail(s)
                       
Image(s)
   
#6
I see the following possible causes of the problem:
  1. Absence or malfunction of the physical connection between the computer and the robot control system.
  2. Unconfigured firewall in the robot control system, in particular, port 7001 is not configured in NAT parameters or its configuration is incorrect.
  3. C3 Bridge Interface Server is still using incorrect port (7000). You need to make sure it is correct by looking at the end of the first line of the log immediately after starting the application.

To exclude the first cause, could you try connecting to the control system using KUKA WorkVisual?
#7
Hello Dmitry, I did it!!! I managed to make the connection in real time with the KUKA KR10 Robot. The problem was the network configuration and the C3bridge was using port 7000. Even though I changed it to 7001, the changes were not made. I solved this by uninstalling and reinstalling the C3Bridge. I am attaching a manual that I made to configure the connection with the KUKA KR10 R1100-2 robot arm and RoboDK in real time. The manual contains the detailed steps (I based myself on an internet publication to perform part of the network configuration: https://camerabotics.com/help-center/har...-robots-to -your-windows-pc/ ). I thank you very much Dmitry for your help!! I hope that this manual I made helps everyone!!!


Attached Files
.pdf   MANUAL DE CONFIGURACIÓN PARA CONEXION EN TIEMPO REAL CON EL CONTROLADOR KRC4 KR10 1100 2.pdf (Size: 1,017.63 KB / Downloads: 30)
  




Users browsing this thread:
4 Guest(s)