Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK Crashes a lot...
#1
Exclamation 
Using MacOS Catalina 10.15.5 - 


 Click RoboDK --> Preferences



.txt   RoboDK Crash Report.txt (Size: 78.17 KB / Downloads: 49)

Would love some suggestions on how to get past this. There are also several other ways I can make RoboDK crash in macOS. Import an object and click "change color".
#2
Just read the entire manual, reinstalled the application, but the problem persists. I am unable to change any Preferences on macOS without a segfault.

Question: since the seg fault is from exec handler, could this be related to the application not having a Gatekeeper certificate? Does the $3500 version include the developer certificate? an Apple developer account is $100 per year and lets you create unlimited application Gatekeeper certificates.
#3
Can you try updating RoboDK to the latest version for Mac?

If you see a crash, to debug this issue better it would help if you can follow these steps:
  1. Close RoboDK
  2. Start RoboDK by running the file:
    /RoboDK/RoboDK-Debug.sh
  3. Try to reproduce the problem in RoboDK until it crashes.
  4. Right after the crash provide us with the following file:
    /RoboDK/RoboDK.app/Concents/MacOS/RoboDK.debug.txt
#4
(07-20-2020, 01:38 PM)Albert Wrote: Can you try updating RoboDK to the latest version for Mac?

If you see a crash, to debug this issue better it would help if you can follow these steps:
  1. Close RoboDK
  2. Start RoboDK by running the file:
    /RoboDK/RoboDK-Debug.sh
  3. Try to reproduce the problem in RoboDK until it crashes.
  4. Right after the crash provide us with the following file:
    /RoboDK/RoboDK.app/Concents/MacOS/RoboDK.debug.txt

Albert, thank you, the newest version seems to be working so far.  I'll update if I find some bugs.  Are there plans to fix the Gatekeeper certificate?
#5
(07-20-2020, 01:38 PM)Albert Wrote: Can you try updating RoboDK to the latest version for Mac?

If you see a crash, to debug this issue better it would help if you can follow these steps:
  1. Close RoboDK
  2. Start RoboDK by running the file:
    /RoboDK/RoboDK-Debug.sh
  3. Try to reproduce the problem in RoboDK until it crashes.
  4. Right after the crash provide us with the following file:
    /RoboDK/RoboDK.app/Concents/MacOS/RoboDK.debug.txt

05:28:12.353 (+0 ms): RoboDK v5.0.0 debug file RoboDK.debug.txt, started on 25-07-2020-05:28:12.353
05:28:12.353 (+0 ms): Debug: OS:  MAC64
05:28:12.353 (+0 ms): Debug: Date build:  Jun 23 2020
05:28:12.353 (+0 ms): Debug: Main process ID:  1250
05:28:12.353 (+0 ms): Debug: Thread ID:  0x11f4f0dc0
05:28:12.459 (+106 ms): Debug: Loading settings...
05:28:12.464 (+5 ms): Debug: Settings loaded
05:28:12.686 (+222 ms): Debug: Statusbar:  "Language set to English"
05:28:12.690 (+4 ms): Debug: Updating recent files menu...
05:28:12.726 (+36 ms): Debug: Created language menu
05:28:12.745 (+19 ms): Debug: Collision check started...
05:28:12.745 (+0 ms): Debug: Collision check time:  0  ms. Collisions:  0     Average:  0  ms
05:28:12.792 (+47 ms): Debug: Setting up graphics...
05:28:12.792 (+0 ms): Debug: Setting up main window...
05:28:12.792 (+0 ms): Debug: Starting main window...
05:28:12.812 (+20 ms): Debug: LC start...
05:28:12.812 (+0 ms): Debug: LC message:  LC device not found
05:28:12.812 (+0 ms): Debug: Dongle not found or cannot read
05:28:12.812 (+0 ms): Debug: LC start...
05:28:12.813 (+1 ms): Debug: LC message:  LC device not found
05:28:12.813 (+0 ms): Debug: Dongle not found or cannot read
05:28:12.815 (+2 ms): Debug: Reading preferred layout settings...
05:28:12.888 (+73 ms): Debug: Initializing OpenGL...
05:28:12.888 (+0 ms): Debug: Initializing OpenGL Functions...
05:28:12.888 (+0 ms): Debug: Initializing OpenGL Shaders...
05:28:12.888 (+0 ms): Debug: Loading vertex 1
05:28:12.889 (+1 ms): Debug: Loading fragment 1
05:28:12.890 (+1 ms): Debug: Loading vertex 2
05:28:12.891 (+1 ms): Debug: Loading fragment 2
05:28:12.892 (+1 ms): Debug: Loading texture vertex 1
05:28:12.894 (+2 ms): Debug: Loading texture fragment 1
05:28:12.897 (+3 ms): Debug: OpenGL Ready
05:28:13.084 (+187 ms): Debug: Done
05:28:13.096 (+12 ms): Debug: Updating window title...
05:28:13.096 (+0 ms): Debug: Entering main loop
05:28:13.236 (+140 ms): Debug: Loading plugin:  "/Users/riddhamanna/RoboDK/RoboDK.app/Contents/MacOS/Plugins/libCollisionFreePlanner.dylib"
05:28:13.241 (+5 ms): Debug: Loading plugin file:  "/Users/riddhamanna/RoboDK/RoboDK.app/Contents/MacOS/Plugins/libCollisionFreePlanner.dylib"
05:28:13.242 (+1 ms): Debug: Loading plugin  "CollisionFreePlanner"
05:28:13.242 (+0 ms): Debug: Using settings:  ""
05:28:13.242 (+0 ms): Debug: Setting up the status bar
05:28:13.251 (+9 ms): Debug: Inserting menu at the end of the utilities menu
05:28:13.252 (+1 ms): Debug: Setting up the menu bar
05:28:13.253 (+1 ms): Debug: List of LOADED plugins:
05:28:13.253 (+0 ms): Debug:      "CollisionFreePlanner"
05:28:13.253 (+0 ms): Debug: Done list of plugins
05:28:13.253 (+0 ms): Debug: Statusbar:  "Loaded 1 plugins"
05:28:13.253 (+0 ms): Debug: Running parameter:  "-DEBUG"
05:28:13.254 (+1 ms): Debug: Silent message:  "Server is running at localhost:20500"
05:28:14.596 (+1342 ms): Debug: LC start...
05:28:14.596 (+0 ms): Debug: LC message:  LC device not found
05:28:14.596 (+0 ms): Debug: Dongle not found or cannot read
05:28:14.596 (+0 ms): Debug: LC start...
05:28:14.597 (+1 ms): Debug: LC message:  LC device not found
05:28:14.597 (+0 ms): Debug: Dongle not found or cannot read
05:28:14.597 (+0 ms): Debug: LC start...
05:28:14.597 (+0 ms): Debug: LC message:  LC device not found
05:28:14.597 (+0 ms): Debug: Dongle not found or cannot read
05:28:14.597 (+0 ms): Debug: LC start...
05:28:14.598 (+1 ms): Debug: LC message:  LC device not found
05:28:14.598 (+0 ms): Debug: Dongle not found or cannot read
05:28:14.598 (+0 ms): Debug: LC start...
05:28:14.598 (+0 ms): Debug: LC message:  LC device not found
05:28:14.598 (+0 ms): Debug: Dongle not found or cannot read
05:28:14.598 (+0 ms): Debug: LC start...
05:28:14.599 (+1 ms): Debug: LC message:  LC device not found
05:28:14.599 (+0 ms): Debug: Dongle not found or cannot read
05:28:15.429 (+830 ms): Debug: LC start...
05:28:15.430 (+1 ms): Debug: LC message:  LC device not found
05:28:15.430 (+0 ms): Debug: Dongle not found or cannot read
05:28:15.430 (+0 ms): Debug: LC start...
05:28:15.430 (+0 ms): Debug: LC message:  LC device not found
05:28:15.430 (+0 ms): Debug: Dongle not found or cannot read

crashes each time I try to acess the Preferences


Attached Files
.txt   RoboDK.debug.txt (Size: 4.17 KB / Downloads: 33)
#6
Can you update to the latest version for Mac?
You tested it on RoboDK v5.0.0 but a new version is available (RoboDK v5.0.1).

Also, I noticed you have collision checking activated. Can you reproduce the issue if you turn off collision checking?
#7
(07-25-2020, 05:37 PM)Albert Wrote: Can you update to the latest version for Mac?
You tested it on RoboDK v5.0.0 but a new version is available (RoboDK v5.0.1).

Also, I noticed you have collision checking activated. Can you reproduce the issue if you turn off collision checking?

I've updated to 5.0.1, and it works!!
Thanks
but I'm running into some other problems that I've posted as a new thread here.
  




Users browsing this thread:
1 Guest(s)