Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK Crashing Because of Graphics Engine?
#1
It looks like I need to update my graphics engine.

RoboDK now crashes on startup after I installed the PTC Creo 3D modeler.  The "safe start" batch file runs RoboDK okay, and looking at the contents of the .bat directed me to the D3D and GPL versions of the RDK build.  Playing with those caused a message box to pop up saying htat the 3D files are out of date, so I suspect that Creo loaded outdated files on top of the ones RoboDK loaded (or maybe they were already in place--reinstalling RoboDK didn't refresh to graphics files).

Is there a simple way to update the 3D engine?

There are so many directions I could go, I don't want to start poking around and end up in the weeds.  Can someone shed some light on this?  Crash report excerpt below.

-Leland

CRASH REPORT
Debug: Initialising main window...
Debug: Reading preferred layout settings...
Debug: Done
Warning: Vertex shader for simpleShaderProg (MainVertexShader & PositionOnlyVertexShader) failed to compile
Warning: Fragment shader for simpleShaderProg (MainFragmentShader & ShockingPinkSrcFragmentShader) failed to compile
Warning: QGLShaderProgram: shader programs are not supported
Critical: Errors linking simple shader:
Warning: Vertex shader for blitShaderProg (MainWithTexCoordsVertexShader & UntransformedPositionVertexShader) failed to compile
Warning: Fragment shader for blitShaderProg (MainFragmentShader & ImageSrcFragmentShader) failed to compile
Warning: QGLShaderProgram: shader programs are not supported
Critical: Errors linking blit shader:
  




Users browsing this thread:
1 Guest(s)