Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

RoboDK application automatically inserts robot seslection

I am a new user to RoboDK and I am experiencing some issues that may be software errors or may be these are normal operations based off of some default settings that I would like to disable or understand.

Dell: M4600 Precision Laptop
OS: Windows 7 64-bit edition
CAD: Autodesk Inventor 2021 Build 289, Release 2021.2
RoboDK V5.2.0 (64 Bit)
I followed along with the documentation and online examples for creating a project. Once I started the project, I renamed the station and saved the project as "PMAI56_Automation_1_2_2021.rdk". loaded in a Kuka robot and some step files to create the automation project while saving the file frequently. After working on the project for a few hours trying different settings with frames and targets, I saved the project and closed the application. This is where I ran into a problem, when I open the project again double clicking the file “PMAI56_Automation_1_2_2021.rdk” in the windows explorer I had two instances of the application start, the first instance had a new station (1) and my project in the project tree. When I clicked on the station (1) project, there was a Mecademic robot selected with a chip8 emulator. I know these objects where not in my file when I saved it. In addition to my project being modified, the second instance of RoboDK had the new station (1) project with the same Mecademic robot and chip8 emulator loaded with my project.

I closed both instances of the RoboDK application and tried just starting the application from the Windows start menu. I clicked on the RoboDK application, again, two instances of the program started. One instance had the New station (1) with the Mecademic robot and the chip8 emulator selected, the second instance has the same Mecademic robot and Chip8 emulator loaded except in this project the robot is running a motion profile based off the Chip8 emulator, again I am only started the application.

Also, I have a different issue, when working in Autodesk Inventor and I have an assembly file open and I select the RoboDK menu selection, there should be some type of option pick list visible, there is nothing. If I open a single part from that assembly and choose the RoboDK menu there are two selection groups visible “CAD” & “CAM” , again there are no visible picklist items to choose from. If scroll the mouse pointer along the selection groups you will see the tool tip name appear. Inside of the CAD group is “Auto Setup”, “Load Part”, “Load Points”, “Load Curves”, & “Settings” and under the CAM group is “Load NC Program” & “Generate Program”, again there is no visible icons to select.

Users browsing this thread:
1 Guest(s)