Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK connect to KUKA Robot/KRC4 Controller problem
#1
Hi there,

I'm working on a KUKA KR-10 R1100-2 robot with KR-C4 Controller and a Ubuntu desktop (I used my Windows laptop too, but the results are the same).
I'm really interested in the 3D printing features of RoboDK for arm robots. So, I need to connect RoboDK to the robot.
I've done everything including adding port 7000, running KUKAVARPROXY.exe, and connecting the LAN cable.
I can ping the robot IP (read from the teach pendant "network configuration" section, which is 172.31.1.147 by default) but I cannot get joint positions or connect to it. It doesn't matter if I'm running RoboDKsynchXX.src or not. The ping command is successful but cannot connect.


There are several things that I need to make sure if I've done correctly:
  1. Should I connect the LAN cable to port X69 of the KR-C4? There are several LAN ports on the controller.
  2. The successful ping is only achievable if I turn off my WiFi connection and use only the wired connection. Otherwise, even pinging is unsuccessful.
  3. I added the mentioned variables to the $config.dat file in KRC:\R1\System\$config.dat (in the teach pendant) or C:\KRC\Roboter\KRC\R1\System\$config.dat. Is that the correct config file?
Please let me know if any other information is required to troubleshoot my problem.

Thanks,
Poe
#2
I managed to connect the robot.
For those who have the same problem:
1- Connect Lan cable to X66 port.
2- Set "Default Gateway" from SmartPad in Settings --> Start-up --> Network Configuration to the same value as IP address (172.31.1.147 by default).
  




Users browsing this thread:
1 Guest(s)