Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK for Raspberry Pi
#1
Good morning, all. 

I have been trying to install and run RoboDK on a Raspberry Pi for the last few days with zero success.
I have been following the instructions in the instructions file but keep getting displayed the following messages after attempting to install dependencies and then running the program itself. I've tried installing the missing dependency packages manually but to no avail. They are reported missing again. Some help and guidance would be greatly appreciated. It doesn't seem like many people have openly documented their use of this program yet. 

I'd really like to use this software on the Raspberry Pi. 

Kind regards, 
Rowan


Attached Files Thumbnail(s)
       
#2
When I execute the start program, it gets to "Created language menu" and just pauses there indefinitely.
#3
Can you try running RoboDK as root?
Code:
sudo ./RoboDK-Start.sh
Also, try to update/upgrade your Linux system before running the RoboDK install script or running the dependency install script.
Code:
sudo apt update
sudo apt upgrade
#4
Thank you for your prompt reply. 

I'm still getting the same messages, unfortunately. 
I'm going to re-flash my SD card and try again from scratch doing the updates and upgrades before installation. 
Where is the best place to install RoboDK? I'm currently installing it on the desktop. 

Happy Easter and kind regards, 
Rowan
#5
Do you have internet connection when you run the install scripts?

Make sure to have internet connection when you run the install scripts and when you update your system.
#6
I just tried installing the latest version of RoboDK for the Raspberry Pi 3B+ and the latest Raspbian Desktop Image (32 bits) and I was able to reproduce your issue. 

It looks like the problem is regarding OpenGL/EGL configuration or drivers.

What Raspberry hardware are you trying to use?
#7
I am running into similar issues. I have a RPI4 8gb. I installed 64bit rasbian bullseye. I’ve tried it several times. Updating before start, installing Qt5, etc etc. have tried running as root as well. Wondering if anyone has any advice?? Thanks!!
  




Users browsing this thread:
1 Guest(s)