Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RoboDK joint position does not match actual UR joint position
#1
I have manually created a program for our UR10e robot using Polyscope on the teach pendant that works excellently. We execute several G-Code toolpaths within, using remote routers (Remote TCPS). I am attempting to recreate this program in RoboDK. I have entered into RoboDK all the RTCP positions and targets as they are indicated in the robot program. However, when I move to a target in RoboDK, I notice that the joint positions are not the same as they are on the actual robot; some off by several tenths of a degree; others as many as 6 to 8 degrees. (I have checked all the various Change config. options available). Is there a way to calibrate RoboDK to precisely reflect the positioning of the actual robot program, which I assume will be necessary to properly execute it? I am concerned that I will not be able to create a program offline that runs accurately on the robot without considerable tweaking afterwards, to align it correctly with the remote TCPs and/or the Base.

Does anyone have thoughts or suggestions?

Thanks,
Bruce
#2
When you create Cartesian targets in RoboDK, the joint coordinates are calculated and recorded as well with the active tool and active coordinate system. If you move the tool or the coordinate system, the original joints don't change. This behavior allows remembering the configuration that was used when the target was first taught.

If you want to recalculate the joint values for Cartesian targets you can force to recalculate all targets by following theses steps:
  1. Right click a program that links to your targets.
  2. Select Recalculate Targets
This will recalculate the joint values for the current position of the tool and reference frames.

If you want this operation to happen automatically every time you generated a program, we recently added the following option that will allow you to do so:
  1. Select Tools-Options
  2. Select the Program tab
  3. Check the option Recalculate targets before generation
Another topic, if you have a remote TCP setup (RTCP), you may want to generate many points along lines to better constrain the tool to remain in the path. You can achieve this by changing these settings:
  1. Select Tools-Options
  2. Select the Program tab
  3. In Output for linear movements, set the Maximum step (mm) to 5 mm or something smaller.
  




Users browsing this thread:
1 Guest(s)