Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED: connection problems when connecting Techman robot to RoboDK
#1
This is not really a question but more me sharing a solution to a problem I encountered.

When trying to connect RoboDK to a Techman robot (for instance for live running of your robot program), I encountered the problem that sometimes everything worked and other times it didn't.


When trying to connect to the robot I could ping the connection which worked and I could tell the robot to move to a position which caused the robot to start to move (in a random way) but I couldn't retrieve the current position of the real robot into RoboDK.

The solution to this problem is really simple: the Modbus protocol on the Techman robots (which is used by de RoboDK TMDriver.py) looks for a connection on startup of the robot. If a connection is found the Modbus protocol stays activated and everything works. If no connection is found during the startup of the robot, Techman 'turns off' the Modbus connection.
So to prevent the problem from happening you need to make sure you have connected your PC to the Techman robot before turning the robot on.

Once the robot is turned on and the connection is established it is possible to remove and re-plug the Ethernet connection without the Modbus connection turning off.

I hope this helps anyone who encounters the same problem.

Note: This was tested on a TM robot version: 3.2 HW and 1.76 SW.
#2
Hi Tico,

Nice one.
I didn't know that.

I found and solved many bugs so far, but never stumbled on this one.
If I do I won't have to look too far thanks to you.

Also, make sure you are using the latest post-processor and driver.
You can download them from here:
https://robodk.com/files/shared/Omron/

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#3
(12-10-2020, 03:05 PM)Jeremy Wrote: Hello guys,

I am using RoboDk trial license . i am trying to connect techman TM5-900 robot with robodk , the ping is successful but when i try to connect i am getting this error message "No connection made because target machine actively refused it " . i have created a program with robodk and trying to sent it to the robot. 

Is there any other procedure to connect with techman robot?
#4
Look at this video and let me know if it works:
https://youtu.be/buM1feEPiBE

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#5
(05-17-2021, 11:30 AM)saravanan Wrote:
(12-10-2020, 03:05 PM)Jeremy Wrote: Hello Jeremy, I followed the procedures as per the video which you have sent. After successful ping, i am not able to communicate Robodk and techman robot, I am attaching the error log file for reference.
#6
Hi,

There is no error log file attached.

Did you properly setup the "Listen node" on TM side?
Did you start the Listen node program before trying to connect?

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#7
[attachment=2190 Wrote:[attachment=2191]Jeremy pid='8660' dateline='1621954370']Hi,

There is no error log file attached.

Did you properly setup the "Listen node" on TM side?
Did you start the Listen node program before trying to connect?

Jeremy

Hi,

I have attached log file now , I could ping the robot successfully but when i try to get joint position of robot as shown in the instruction video , i am unable to connect.  I also did troubleshooting and the IP address was correct and there was no issue with packet loss. i have disable firewall as well. Kindly help me regarding this issue.
#8
Hi,

"No connection made because target machine actively refused it "
This means what it means, the "issue" is on TM Flow side I believe.

Did you properly activate the Modbus and Ethernet communication on your controller?
Are you connected to the Ethernet port that does accept Modbus communication? (There is 3 RJ-45 port on the controller, use the one "alone".)
Did your listen node program was running before pressing "Get position"?
Did you try just the "Commands" from the connection interface?

If you change the port or if you activate Modbus or Ethernet, I'm pretty sure you need to restart your controller for it to take effect.

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


#9
(05-27-2021, 11:38 AM)Jeremy Wrote: Hi,

"No connection made because target machine actively refused it "
This means what it means, the "issue" is on TM Flow side I believe.

Did you properly activate the Modbus and Ethernet communication on your controller?
Are you connected to the Ethernet port that does accept Modbus communication? (There is 3 RJ-45 port on the controller, use the one "alone".)
Did your listen node program was running before pressing "Get position"?
Did you try just the "Commands" from the connection interface?

If you change the port or if you activate Modbus or Ethernet, I'm pretty sure you need to restart your controller for it to take effect.

Jeremy

Hi,

Thank you for the help , i changed the ethernet port as you mentioned and i was able to communicate with robot.

I am working on a simple project where i need to rotate a shaft type component 180 degree after picking it, like a rotary actuator. How can i create a simple rotation mechanism which will also be the Robot TCP .
#10
Hi,

This video should help you. https://youtu.be/HN9bHHGyVOk
Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)