Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED: connection problems when connecting Techman robot to RoboDK
#1
This is not really a question but more me sharing a solution to a problem I encountered.

When trying to connect RoboDK to a Techman robot (for instance for live running of your robot program), I encountered the problem that sometimes everything worked and other times it didn't.


When trying to connect to the robot I could ping the connection which worked and I could tell the robot to move to a position which caused the robot to start to move (in a random way) but I couldn't retrieve the current position of the real robot into RoboDK.

The solution to this problem is really simple: the Modbus protocol on the Techman robots (which is used by de RoboDK TMDriver.py) looks for a connection on startup of the robot. If a connection is found the Modbus protocol stays activated and everything works. If no connection is found during the startup of the robot, Techman 'turns off' the Modbus connection.
So to prevent the problem from happening you need to make sure you have connected your PC to the Techman robot before turning the robot on.

Once the robot is turned on and the connection is established it is possible to remove and re-plug the Ethernet connection without the Modbus connection turning off.

I hope this helps anyone who encounters the same problem.

Note: This was tested on a TM robot version: 3.2 HW and 1.76 SW.
#2
Hi Tico,

Nice one.
I didn't know that.

I found and solved many bugs so far, but never stumbled on this one.
If I do I won't have to look too far thanks to you.

Also, make sure you are using the latest post-processor and driver.
You can download them from here:
https://robodk.com/files/shared/Omron/

Jeremy
Find useful information about RoboDK and its features by visiting our Online Documentation and by watching tutorials on our Youtube Channel


  




Users browsing this thread:
1 Guest(s)