Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

Sending programs to raspberry pi via FTP


I set up an FTP server on a raspberry pi according to the tutorial:

It works, I send files via FileZilla.

When I try to send a program from RoboDK by selecting "Send program to robot" it doesn't work. I get a message: "Remote path not found or can't be created: /home/pi/FTP/files"
In the "Connect robot" window, I enter the same parameters as in FileZilla

Do you have an idea what I did wrong? What can I improve?
It looks like the FTP connection worked but the path does not exist.

Does the folder exist?
Did you use the correct user name and password? (with enough privileges to transfer files and create folders)
In the "Connect robot" window, I enter exactly the same data as in Filezilla. In Filezilla it works, in RoboDK it doesn't.
Perhaps I should configure something in the options of RoboDK itself?
I have solved my problem.

My mistake was entering the full location of the FTP folder in the 'Remote FTP path' field.
Following the tutorial, we add the following lines to the vsftpd.conf file:
This already indicates the location of the FTP folder. So if I enter only '/files' in "Remote FTP path" in "RoboDK , everything works correctly.

Users browsing this thread:
1 Guest(s)