Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Setting robot start point on a milling project
#1
Hi Everyone,

I am a newbie to robotics, but have 15 years experience in the stone sculpting trade. I have a Kuka KR120 2700 and I purchased a license of RoboDK. I would really appreciate tips on how to setup the start position of my milling project.

How do I set Robot start point? I ran a simple joint movement program today and my robot wanted to turn almost 180'

Mike Rhodes

Any help would be priceless for me!

MR
#2
Did you move the robot using a joint movement to a Cartesian target (XYZABC) or a joint target (A1-A6 axis values)?

Can you share your RoboDK project (RDK file)? We can help you better.
#3
Hi Albert. Her is a rough drawing of my cell. The large block in the center is where my rotating 7th axis is. This is obviously a very rough drawing. my Kuka is located directly adjacent to this. Here are the files. When I go to run this basic movement program on the robot, it wants to move 180 degrees in the direction facing away from the table.

Here you go Albert.

Thank you so much :)


Attached Files
.iges   KUKA KR120 CELL robodk.iges (Size: 68.87 KB / Downloads: 5)
.rdk   KUKA KR120.rdk (Size: 1.03 MB / Downloads: 5)
#4
Of, and I moved the robot via the A1-6 Values. I also need to change the software limits on the Kuka as well.
#5
Can you confirm if you are using the default post processor? The same one you have selected and you did not make any edits.

To clarify, you tested the following program:
Code:
; ---- Setting reference (Base) ----
; BASE_DATA[2] = {FRAME: X 1593.300,Y -199.697,Z 46.295,A 5.000,B 0.000,C 0.000}
$BASE = {FRAME: X 1593.300,Y -199.697,Z 46.295,A 5.000,B 0.000,C 0.000}
; $BASE = BASE_DATA[2]
; --------------------------
; ---- Setting tool (TCP) ----
$TOOL = {FRAME: X 0.000,Y -20.000,Z 430.000,A 0.000,B 30.000,C 0.000}
; --------------------------
PTP {A1 4.74577,A2 -117.26100,A3 114.05000,A4 124.00800,A5 -5.72799,A6 -124.14100,E1 0.00000}
PTP {A1 -10.94070,A2 -95.69690,A3 91.55630,A4 249.51800,A5 -11.68910,A6 -249.12100,E1 0.00000}
END

And when moving the robot to the first joint axis movement (first PTP), then, axis 1 turns 180 deg? It could be that the robot base is turned 180 deg around Z. If you could share a picture or specify better what the robot is trying to do we can help you troubleshoot.

Was this robot ever part of another system with external axes such as a rail or a turntable? Or did you purchase directly from KUKA? This can help chase the issue.

Also, I noticed your coordinate system Frame 2 has A value 5 deg. Is this correct?
#6
I forgot to attach your RDK project file with the cell included (IGES file). I split the table and the layout. I'm not sure if this represents your real setup. I don't think so because the part is on the floor. Can you confirm?


Attached Files
.rdk   KUKA KR120-v2.rdk (Size: 1.03 MB / Downloads: 3)
#7
Dear Albert,

Thank you so much for your reply. I am going to try an be a thorough as I can this time with our setup.

The robot was purchased used from a company called Old Word Stone and it was integrated by a company called New Age Robotics. Everything was in perfect function and they were using it to mill stone for repairs on old architecture.

This is the integration company. https://robotics.ca/

I have called the owner of NAR and he advised that they no longer integrate robotic milling cells. I had another company come in to help us integrate this cell into our shop, but they had to reverse engineer EVERYTHING just to get it to what it is now. I have attached pictures of our cell (excuse the mess!) and also a more accurate model of our spindle.

I have not modified anything in the post processor as I am a beginner with your software. I would not dare mess with anything like this because I have no business doing so with my knowledge base.

Everything works right now. E1 is interpolated with the other 6 axis, the water comes on when activated, compressed air with chuck and un-chuck works perfectly and everything else I need to mill is GTG.

I just cannot figure out for the life of me when I try to run a basic PTP or joint movement, it is behaving this way!


Frame 2 should not be off 5 degrees.

Here are the files :)


Attached Files
.zip   HGH CELL.zip (Size: 1.75 MB / Downloads: 6)
#8
Forgot to mention Albert, that WAS the exact program I tried to run. I must be missing something possibly with the KRC4 controller somehow.

I included pictures of settings on my pendant as well.
#9
Hello Mike!

I noticed external axis E1 on the Kuka's teach pendant on the photos that you sent us. That issue can be caused by the external axis which is connected to the robot in cooperation mode.

Could you please tell us the coordinates and joint values at the points I have drawn in the pictures?
Also, could you clarify please what TCP coordinates are currently set on the robot? For point measurements, you can use any tip with a known length.


Attached Files Thumbnail(s)
       
  




Users browsing this thread:
Sergei, 1 Guest(s)